<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>Soor: A Third-Party Apple Music Client for iPhone &#8211;  MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

!function(o){"use strict";var t="b7d8d8403046423987bce7fdbfa25f1d697eea0f",e=function(){var o=document.createElement("style");o.rel="stylesheet",document.head.appendChild(o),o.textContent=localStorage.sourceSansPro};try{var a=!!localStorage.sourceSansPro,n=localStorage.sourceSansProVersion===t;if(a&&n)e();else{var s=function(o){var e="woff";if("FontFace"in o){var a=new o.FontFace("t",'url( "data:application/font-woff2," ) format( "woff2" )',{});a.load()["catch"](function(){}),e="loading"===a.status?"woff2":"woff"}return"https://cdn.rawgit.com/vendruscolo/webfonts/"+t+"/source-sans-pro."+e+".css"}(o),r=new XMLHttpRequest;r.open("GET",s,!0),r.onload=function(){r.status>=200&&r.status<400&&(localStorage.sourceSansProVersion=t,localStorage.sourceSansPro=r.responseText)},r.send()}}catch(c){}}(this);

</script>

<!-- All in One SEO Pack 2.4.3.1 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<meta name="keywords"  content="apple music,music" />

<link rel="canonical" href="https://www.macstories.net/reviews/soor-a-third-party-apple-music-client-for-iphone/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Connected, Episode 232: The Unique Blend of Tattoos and Automation' href='https://www.macstories.net/linked/connected-episode-232-the-unique-blend-of-tattoos-and-automation/' />
<link rel='next' title='Apple’s Month-Long Celebration of International Women’s Day' href='https://www.macstories.net/news/apples-month-long-celebration-of-international-womens-day/' />
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='https://www.macstories.net/?p=58283' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fsoor-a-third-party-apple-music-client-for-iphone%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fsoor-a-third-party-apple-music-client-for-iphone%2F&#038;format=xml" />
<link rel="alternate" type="application/json" title="MacStories &raquo; JSON Feed" href="https://www.macstories.net/feed/json/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@viticci">    <meta property="og:description" content="Soor, a third-party client for Apple Music created by indie developer Tanmay Sonawane, is based upon a fascinating premise: unlike other standalone music players for iPhone, Soor works with Apple's native MusicKit API, enabling direct integration with Apple Music; unlike Apple's Music app though, Soor prioritizes one-handed gestures, user customization, and a single-page design that [&hellip;]">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="Soor: A Third-Party Apple Music Client for iPhone">
    <meta property="og:url" content="https://www.macstories.net/reviews/soor-a-third-party-apple-music-client-for-iphone/">
    <meta property="og:image" content="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-27-23-50-35.png">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>
        window.MS_INITIAL_THEME = window.localStorage.theme;

        var _paq = _paq || [];
        /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
        _paq.push(['trackPageView']);
        _paq.push(['enableLinkTracking']);
        (function() {
            var u="//minticci.macstories.net/";
            _paq.push(['setTrackerUrl', u+'piwik.php']);
            _paq.push(['setSiteId', '1']);
            var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
            g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
        })();

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_INITIAL_THEME
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_PUSH_OPTIONS_ARGS = {
            baseURL : 'https://push.macstories.net',
            pushId : 'web.net.macstories.production',
            categories : {
                'News' : 1,
                'Reviews' : 6,
                'Stories' : 7,
                'Linked' : 5129            }
        }

        MS_IFRAMES = [];
        MS_HandleIframeLoad = Array.prototype.push.bind(MS_IFRAMES);
    </script>

</head>

<body class="post-template-default single single-post postid-58283 single-format-standard">
<script>document.body.classList.add(window.MS_INITIAL_THEME)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
        <div><a href='' target='_blank'><img class='ms-custom-ad' /></a></div><script>document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? '' : ''</script>    </div>

    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://appstories.net/">PODCAST</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://club.macstories.net/?utm_source=ms&#038;utm_medium=nav_menu">MEMBERSHIP</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-explore" class="menu dropdown-menu"><li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="https://www.macstories.net/tag/app-store-10/">APP STORE AT 10</a><a class="feed-icon" href="https://www.macstories.net/tag/app-store-10/feed"></a></li>
<li id="menu-item-47663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47663"><a href="https://www.macstories.net/ipad/">IPAD</a><a class="feed-icon" href="https://www.macstories.net/ipad/feed"></a></li>
<li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APPS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
<li id="menu-item-47615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47615"><a href="https://www.macstories.net/tag/automation+ios/">IOS AUTOMATION</a><a class="feed-icon" href="https://www.macstories.net/tag/automation+ios/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <span class='js-theme-trigger action-icon'><svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd"><path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path></g></svg>

</span>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-58239">
    <a class='post-thumbnail' href="https://www.macstories.net/stories/why-the-siri-face-is-all-i-need-from-my-apple-watch/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-26-23-14-11.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/stories/why-the-siri-face-is-all-i-need-from-my-apple-watch/" rel="bookmark">Why the Siri Face Is All I Need from My Apple Watch</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-58072">
    <a class='post-thumbnail' href="https://www.macstories.net/ipad-diaries/ipad-diaries-using-a-mac-from-ios-part-1-finder-folders-siri-shortcuts-and-app-windows-with-keyboard-maestro/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-07-18-07-31.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/ipad-diaries/ipad-diaries-using-a-mac-from-ios-part-1-finder-folders-siri-shortcuts-and-app-windows-with-keyboard-maestro/" rel="bookmark">iPad Diaries: Using a Mac from iOS, Part 1 – Finder Folders, Siri Shortcuts, and App Windows with Keyboard Maestro</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-57918">
    <a class='post-thumbnail' href="https://www.macstories.net/ios/hands-on-with-ios-12-2s-homekit-support-for-smart-tvs/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-01-26-19-13-29.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/ios/hands-on-with-ios-12-2s-homekit-support-for-smart-tvs/" rel="bookmark">Hands On with iOS 12.2&#8217;s HomeKit Support for Smart TVs</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
                    <h3 class="fan-heading">This week's sponsor</h3>
            <div class="fan-text">
                <a class='fan-link' href='https://itunes.apple.com/us/app/home-smart-home-automation/id995994352' target='_blank'>Home</a>
                <div class='fan-description'><p>A Powerful, Flexible Alternative to Apple&rsquo;s Home App</p>
</div>
            </div>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-58283 type-post status-publish format-standard hentry category-reviews tag-apple-music tag-music" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2019-02-28T07:43:23-05:00"></time>            </div>
        
        <h1 class='post-title'>
            Soor: A Third-Party Apple Music Client for iPhone        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/viticci/" rel="author">By Federico Viticci</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper" id="div1"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-27-23-50-35.png" alt=""></div>
<p id="p2"><a href="https://itunes.apple.com/us/app/id1439731526?at=10l6nh&amp;ct=ms_inline">Soor</a>, a third-party client for Apple Music created by indie developer <a href="https://tanmay.me/">Tanmay Sonawane</a>, is based upon a fascinating premise: unlike other standalone music players for iPhone, Soor works with Apple's native <a href="https://developer.apple.com/musickit/">MusicKit API</a>, enabling direct integration with Apple Music; unlike Apple's Music app though, Soor prioritizes one-handed gestures, user customization, and a single-page design that packs multiple sections into one view. In theory, Soor should be the optimal blend of two different worlds &ndash; a third-party music player with its own aesthetic and stylistic choices combined with Apple Music data and the service's vast streaming catalog. In practice, while <a href="http://soor.app/">Soor</a> has some solid ideas I'd like to see in Apple Music too, and despite its intriguing visual design, the app doesn't qualify as a complete replacement for the Music app on iPhone.</p>
<p id="p3"><span id="more-58283"></span></p>
<p id="p4">Two years ago, Apple introduced MusicKit, a developer framework and set of APIs that allowed iOS developers to create apps compatible with Apple Music. From utilities such as <a href="https://itunes.apple.com/us/app/id284993459?at=10l6nh&amp;ct=ms_inline">Shazam</a> and <a href="https://itunes.apple.com/us/app/id1097974566?at=10l6nh&amp;ct=ms_inline">SongShift</a> to standalone players and fully-featured clients, MusicKit aimed to provide the native alternative to Spotify's web API that had been missing from the iOS music app ecosystem. As <a href="https://www.macstories.net/stories/ios-11-the-macstories-review/11/#musickit">I wrote in my review of iOS 11</a>:</p>
<blockquote id="blockquote5"><p>
  MusicKit enables apps to integrate with Apple Music and get access to artists, albums, songs, playlists, and even activities and curators. The MusicKit API returns JSON results and supports discovery operations such as search, charts, and personalized recommendations. To do this, iOS 11 has a new music permission dialog with a purpose string that explains why an app wants to access your Apple Music library and account.</p>
<p>  I expect MusicKit to spark a creative, diverse ecosystem of music utilities &ndash; from alternative clients that stream songs saved in your library (if Apple allows them on the App Store) to fitness apps with deeper Apple Music integration. It&rsquo;ll be interesting to see if MusicKit becomes as popular as the Spotify API &ndash; at least on the iOS App Store.
</p></blockquote>
<p id="p6">Two years later, it's fair to say music utilities have benefited from MusicKit's native integration with Apple Music and the user's local music library, but alternative clients have fared better on a platform where an Apple Music app is not available &ndash; the open web. In the past year alone, thanks to the <a href="https://developer.apple.com/videos/play/wwdc2018/506">introduction of MusicKit for the web</a>, we've seen the release of <a href="https://9to5mac.com/2018/12/14/apple-music-web-player/">several</a> web apps that <a href="https://musi.sh/">replicate the Apple Music experience in a browser</a> &ndash; often with an attention to detail and polished design that might even pass for an official Apple product. I suppose this is a logical consequence: from a user's perspective, it makes more sense to gain access to Apple Music on a platform that doesn't have a dedicated, built-in Music app than to install an alternative Apple Music player on an iPhone, which already has a pre-installed, full-featured app from Apple. But if that's the case, where does Soor fit in?</p>
<h2 id="a-customizable-home-screen">A Customizable Home Screen</h2>
<p id="p7">The main selling point of Soor is its single-page design with sections that can be customized and rearranged by the user. Soor doesn't have a tab bar, which means that from a single home screen you'll have access to:</p>
<ul id="ul8"><li>Your playlists</li>
<li>Recently played</li>
<li>Recently added</li>
<li>Apple Music's hot tracks</li>
<li>Top playlists </li>
<li>New releases</li>
<li>Top songs</li>
<li>Apple Music's For You section</li>
</ul><p id="p9">With the exception of For You (more on this below), all these sections can be turned off in the app's settings and rearranged so that, for instance, your playlists and recently played albums are at the top of the screen, with Apple Music sections following down in the middle. Soor's key proposition is this drastic departure from the organization of the Music app: rather than splitting the Library and For You into two separate tabs, Soor lets you mix and match both types of content in the same screen, enabling you to choose the order they're displayed for faster access.</p>
<div class="media-wrapper" id="div10"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-27-23-52-24.png" alt=""></div>
<p id="p11">In the several weeks I've spent testing Soor on my iPhone, this has turned out to be my favorite aspect of the app. In an old issue of our <a href="https://club.macstories.net/">MacStories Weekly newsletter</a> (#154), Ryan argued in favor of a customizable For You page in the Music app, noting how Apple should consider letting users personalize the order of blocks displayed in what is, for many, the default view of Apple Music. Soor delivers on that idea with the ability to decide which sections you want to see and where they should be placed. In everyday use, the end result is a music app that can be faster to operate than Apple Music because the playlists, albums, or songs you care about are just two taps away. Everyone's music preferences are different; the flexible, modular approach of Soor is exactly what I'd like to see in the future of Apple Music too.</p>
<p id="p12">I should also note how Soor's design fits the modern iOS ecosystem but does a better job at balancing information density than Apple's own app. Compare Music's presentation of the For You page and your playlists to the same screens as viewed in Soor:</p>
<div class="media-wrapper" id="div13"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-28-00-14-21.png" alt="Comparing the For You and Playlist pages between Music and Soor."><p class="image-caption">Comparing the For You and Playlist pages between Music and Soor.</p></div>
<p id="p14">Thanks to smaller thumbnails and (scrollable) grids, Soor is able to display more content on screen, thus increasing the speed and comfort of navigation between sections. By contrast, where Apple Music once felt bold and intuitive, it now appears overly sparse and limited. Again, I would love for a future version of Apple Music to let me select the density of content aggregated in the For You page, much like iOS allows me to choose its system-wide font size with <a href="https://developer.apple.com/videos/play/wwdc2017/245/">a simple slider</a>.</p>
<h2 id="musickit-and-for-you">MusicKit and For You</h2>
<p id="p15">In terms of actually playing music, even though Soor has its own Now Playing screen, under the hood it uses Apple Music's audio engine and player. This means that when a song is playing in Soor, it'll also appear as playing in the Music app because Soor is merely a different front-end interface for the same underlying service. Playing a song in Soor will be reflected in Control Center and the Apple Watch as if it were playing in Music; similarly, if you start playing something in Soor then force-quit the app, it'll continue to play because, behind the scenes, playback is managed by the Music app.</p>
<p id="p16">There's one notable omission (the first in a long list): unlike the Music app, Soor does not support AirPlay 2, so you won't be able to stream to multiple AirPlay 2 speakers at once or control what's playing on them on a separate channel from your iPhone's system audio. According to Sonawane, AirPlay 2 is one of the features he's planning for future updates to the app, but &ndash; considering the app's price tag &ndash; it would have been nice to have it available at launch.</p>
<p id="p17">The inclusion of the For You section is one of the perks of MusicKit, and it helps achieve a basic degree of feature parity with the Music app. In Soor, the For You section is comprised of a series of content blocks that are always displayed at the bottom of the home screen and cannot be rearranged or split into smaller, individual chunks. These blocks are:</p>
<ul id="ul18"><li>Curated playlists (Favorites Mix, Chill Mix, New Music Mix)</li>
<li>The day's Playlists and Albums</li>
<li>Artist spotlight playlists </li>
<li>New For You</li>
</ul><div class="media-wrapper" id="div19"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-27-23-57-36.png" alt="For You in Apple Music (left) and Soor."><p class="image-caption">For You in Apple Music (left) and Soor.</p></div>
<p id="p20">These are the same sections you'd see in the Music app, but they're available right inside Soor &ndash; much like For You content can also be accessed from the Sonos app after <a href="https://www.macstories.net/notes/apple-music-launching-on-sonos-tomorrow-some-beta-impressions/">you connect an Apple Music account</a>. Notably absent, however, are the Friends Mix and Heavy Rotation playlists, which are exclusive to the Music app. I'm aware of the fact that the Friends mix/feed is not available to the MusicKit API (so there's nothing Soor can do about it), but I have to wonder why For You can't be freely rearranged on screen or why it can't be narrowed down to a subset of playlists or sections.</p>
<h2 id="other-design-peculiarities">Other Design Peculiarities</h2>
<p id="p21">Soor has its fair share of problems, as I'll detail in the section below, but I ought to mention its several visual treats and other design touches that are worth discussing.</p>
<p id="p22">In addition to a standard light theme, Soor supports a true black theme (ideal for OLED displays) and a dark mode based on dark grays and oranges; I like the latter a lot, and I hope Apple has a similar palette in mind for Apple Music in iOS 13.</p>
<div class="media-wrapper" id="div23"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-27-23-59-52.png" alt="Themes in Soor."><p class="image-caption">Themes in Soor.</p></div>
<p id="p24">While Apple's Music app employs a mix of 3D Touch and buttons to reveal contextual menus for songs, playlists, and other items, Soor eschews 3D Touch altogether and uses a combination of popup menus and drag and drop to let users perform actions and manage their queue. Contextual menus are invoked by tapping an ellipsis button next to songs/albums or the artist name in the Now Playing screen. I like how these menus are not modal on iPhone &ndash; they don't take over the entire screen &ndash; but instead feel like contextual menus inspired by macOS. Despite their resemblance to desktop menus, they feel native to iOS: each item in the menu has its own icon, and you can "hover" with your finger over each option to feel a subtle haptic tap and see a highlight around the selected item. As others <a href="https://codea.io/blog/the-ios-menu/">have shown lately</a>, I'm starting to think that desktop-like contextual menus can indeed be adapted to iOS.</p>
<div class="media-wrapper" id="div25"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-28-00-02-00.png" alt="Contextual menus in Soor."><p class="image-caption">Contextual menus in Soor.</p></div>
<p id="p26">Soor differs from Apple Music in how it implements queue management. Soor's contextual menus don't contain any buttons to "play next" or "add to queue"; instead, this is entirely done by dragging songs and placing them in a "drop zone" that features buttons to queue, add songs to playlists, like them, and share them with extensions.<sup id="fnref-58283-share"><a href="#fn-58283-share" class="jetpack-footnote">1</a></sup></p>
<div class="media-wrapper" id="div27"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-28-00-04-13.png" alt="Drag and drop in Soor is technically impressive."><p class="image-caption">Drag and drop in Soor is technically impressive.</p></div>
<p id="p28">This interaction is <em>really</em> well done, and it's now one of the best showcases of drag and drop for iPhone along with <a href="https://www.macstories.net/reviews/castro-3-review-the-castro-youve-always-wanted/">Castro</a>.<sup id="fnref-58283-drop"><a href="#fn-58283-drop" class="jetpack-footnote">2</a></sup> When you're dragging a song and hover over buttons in the drop area, each glyph gets highlighted, plays a haptic tap, and displays a tooltip to indicate it'll activate if you let go of the song. It's even more impressive for playlist management in that if you pause with a song over the playlist button, the drop area will expand and reveal an additional tray of playlists that you can scroll while dragging to select a destination playlist.</p>
<p id="p29">As I mentioned above, Soor's adoption of drag and drop is impressive, both visually and technically speaking. After a few weeks spent using the app, however, I'm not convinced it's necessarily faster than Music's more simplistic, but effective 3D Touch menu. I use 3D Touch <em>a lot</em> in Apple Music to like songs, jump to albums, or add songs to my queue. The gesture is "sloppy" in that it doesn't require hitting a tiny button with too much precision, and I've grown accustomed to pressing with my thumb, selecting a menu option without lifting my finger, then letting go. In using Soor, I found myself missing Music's 3D Touch interaction, and I felt like the app's menus and drag and drop system were slower than Music's press-to-open system in the end.</p>
<p id="p30">I'd also like to highlight Soor's "pull to reach" functionality, a setting designed to aid one-handed operations by letting you pull down on the screen to select toolbar buttons at the top. Think of it like pull to refresh, only it has to be more "intentional" and you have to wait for a toolbar icon to be selected (it'll be highlighted and you'll feel a tap) before you can let go and trigger the button. In Soor, this is presented as an easier way to open settings, activate the search feature, or tweak sorting in playlists because all three of those buttons are placed toward the top of the screen and may therefore be difficult to reach.</p>
<div class="media-wrapper" id="div31"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-02-28-00-09-42.png" alt="Pull to reach to open search."><p class="image-caption">Pull to reach to open search.</p></div>
<p id="p32">I like the sentiment behind pull to reach, which is presented as one of the marquee features of Soor, but in my experience accidental triggers of the pull-down gesture were too frequent to justify leaving the setting enabled. Even with an option to mitigate pull to reach with a 0.5 second delay turned on, I found that I could often trigger search when I was just scrolling in the app without meaning to open search and engage pull to reach. There's definitely <em>something</em> to the idea behind pull to reach, but the current implementation was too unreliable for me to leave it enabled.</p>
<h2 id="soors-problems-and-limitations">Soor's Problems and Limitations</h2>
<p id="p33">I'm going to cut to the chase here: whether by MusicKit limitations or personal decisions of its developer, Soor is affected by a variety of other issues that prevent it from being a full Apple Music client capable of replacing the Music app.</p>
<p id="p34">Soor lacks key features that are part of the modern Apple Music experience. Aside from For You and top songs, most of the other views from Apple Music are missing: artist pages lack profile pictures, they don't separate different types of music releases, nor do they show you artist bios and related artists; there are no music videos either. It's effectively impossible to browse for new music in Soor: Apple Music has a front page that highlights interviews, new releases, and videos; you can browse by genres, check out radio stations, and see a list of noteworthy 'coming soon' releases on the main Browse page; all of this is absent from Soor.</p>
<p id="p35">It gets worse though. Soor does not support Beats 1 at all, has no built-in lyrics, does not work with AirPlay 2, and it's hamstrung by API limitations that, for instance, prevent it from sharing playlist links, seeing what your friends have been listening to, or understanding which tracks in an unreleased album are actually available for streaming or not (if you try to play them, they won't do anything because they're not available yet). The developer is upfront about some of these technical limitations in a built-in FAQ section of the app, but it's hard to tell whether all the other missing features were also due to API restrictions of if they were decisions made during development.</p>
<p id="p36">What's for certain is that Soor is a $10 iPhone app (it doesn't support the iPad in this first version) that is advertised as having "full Apple Music support" while in reality it's a <em>music player</em> that integrates with Apple Music but lacks dozens of features that make up the modern Apple Music experience. It's a subtle difference, but it's where I draw the line in the comparison between Apple's Music app and Soor.</p>
<h2 id="wrap-up">Wrap-Up</h2>
<p id="p37">All of this begs the question: why should you buy <a href="http://soor.app/">Soor</a>?</p>
<p id="p38">It's undeniable that the app has an attractive UI and is perhaps the best example of MusicKit support in a third-party Apple Music client for iOS. But I don't think pretty design and solid API adoption are good enough reasons to recommend a $10 app to people nowadays. Instead, I think you should consider Soor if you're the kind of Apple Music subscriber who doesn't care for all the other features absent from the app (videos, Beats 1, browsing for new music, artist pages, etc.) and wants to get fast access to playlists in a single-page design. The ability to customize the order of sections and put playlists at the top is <em>the</em> feature that sets Soor apart from the Music app. If you're the type of person who pays for Apple Music to stream songs but doesn't care about any of the other modern Apple Music features and just wants to quickly listen to playlists on an iPhone, then I would say Soor is probably for you. Sadly, I have a feeling this is not a huge market, but I could be wrong.</p>
<p id="p39">In many ways, Soor reminds me of <a href="https://www.macstories.net/?s=Ecoute">Ecoute</a>, the music player for iOS that launched well before the days of Apple Music and streaming services. Like Ecoute, Soor brings a different design sensibility to the music player, but it can't be considered a full replacement for the main service it integrates with due to a host of technical restrictions and opinionated choices. For this reason, Soor is ultimately stuck between its vision and the realities of Apple Music: the app lures you with the promise of a beautiful, comprehensive Apple Music listening experience, but it can't fulfill that vision just yet. I hope that its developer will be able to iterate on this first version of the app by shipping an iPad version and supporting all the Apple Music features that can be added to the app. But if you're a heavy Apple Music user, Soor's approach, despite its beauty and cleverness, is too limited to replace Apple's Music app today.</p>
<p id="p40">Soor is <a href="https://itunes.apple.com/us/app/id1439731526?at=10l6nh&amp;ct=ms_inline">available on the App Store at $9.99</a>.</p>
<div class="footnotes" id="div41">
<hr><ol><li id="fn-58283-share">
If you share an Apple Music song with the share sheet, you'll share both the song's name and iTunes link; if you share a track you manually uploaded to iCloud Music Library (which can be played in Soor), you'll only have the song's title.&nbsp;<a href="#fnref-58283-share">&#8617;&#65038;</a>
</li>
<li id="fn-58283-drop">
I <a href="https://www.macstories.net/stories/ios-11-the-macstories-review/20/#iphone-drag-and-drop">continue to believe</a> Apple should enable drag and drop system-wide on iPhone.&nbsp;<a href="#fnref-58283-drop">&#8617;&#65038;</a>
</li>
</ol></div>
            </div>

    
        <footer class='post-footer'>
        <div class="post-tags">Tags: <a href="https://www.macstories.net/tag/apple-music/" rel="tag">Apple Music</a>, <a href="https://www.macstories.net/tag/music/" rel="tag">music</a></div>        </footer>

        
    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it's also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. Plus, it's made in Italy.</p>
<p>Starting at $5/month, with an annual option available. <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline">Join the Club</a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/94a9aa7c70dbeb9440c6759bd2cebc2a?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/viticci/" title="Posts by Federico Viticci" rel="author">Federico Viticci</a></p>
                        <div class='author-bio'><p>Federico is the founder and Editor-in-Chief of MacStories, where he writes about Apple with a focus on apps, developers, and iOS productivity. He founded MacStories in April 2009 and has been writing about Apple since. Federico is also the co-host of <a href="https://appstories.net/">AppStories</a>, a weekly podcast exploring the world of apps.</p>
<p>He can also be found on his three other podcasts on Relay FM &ndash; <a href="http://www.relay.fm/connected">Connected</a>, <a href="https://www.relay.fm/canvas">Canvas</a>, and <a href="http://www.relay.fm/remaster">Remaster</a>.</p>
</div>
        <p class='author-contact-info'>
        <span class='twitter'>Twitter: <a href='https://twitter.com/viticci' target='_blank'>@viticci</a></span><span class='separator'> | </span>
        <span class='instagram'>Instagram: <a href='https://instagram.com/viticci/' target='_blank'>@viticci</a></span><span class='separator'> | </span>
        <span class='email'>Email: <a href='mailto:viticci@macstories.net'>viticci@macstories.net</a></span>
        </p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-footer" class="menu"><li id="menu-item-54441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54441"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-54439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54439"><a href="https://www.macstories.net/club/">MEMBERSHIP</a></li>
<li id="menu-item-54440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54440"><a href="https://www.macstories.net/advertise/">SPONSORSHIP</a></li>
<li id="menu-item-54438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54438"><a href="https://www.macstories.net/privacy-policy/">PRIVACY POLICY</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='http://pixelcave.net' target='_blank'>Silvia Gatta</a> | Hosted by <a href="https://www.macstadium.com/macstories" target="_blank">MacStadium</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2019 MacStories. All rights reserved.</span>

    <span class='version'>v4.4.4.1
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201909'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20180525.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20160913.js'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>

</body>
</html>


