<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>Streaks 4 Adds iPad Support, Timed Tasks, HealthKit Improvements, and Siri Shortcuts &#8211;  MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

!function(o){"use strict";var t="b7d8d8403046423987bce7fdbfa25f1d697eea0f",e=function(){var o=document.createElement("style");o.rel="stylesheet",document.head.appendChild(o),o.textContent=localStorage.sourceSansPro};try{var a=!!localStorage.sourceSansPro,n=localStorage.sourceSansProVersion===t;if(a&&n)e();else{var s=function(o){var e="woff";if("FontFace"in o){var a=new o.FontFace("t",'url( "data:application/font-woff2," ) format( "woff2" )',{});a.load()["catch"](function(){}),e="loading"===a.status?"woff2":"woff"}return"https://cdn.rawgit.com/vendruscolo/webfonts/"+t+"/source-sans-pro."+e+".css"}(o),r=new XMLHttpRequest;r.open("GET",s,!0),r.onload=function(){r.status>=200&&r.status<400&&(localStorage.sourceSansProVersion=t,localStorage.sourceSansPro=r.responseText)},r.send()}}catch(c){}}(this);

</script>

<!-- All in One SEO Pack 2.4.3.1 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<meta name="keywords"  content="fitness,health,ios 12,productivity,shortcuts" />

<link rel="canonical" href="https://www.macstories.net/reviews/streaks-4-adds-ipad-support-timed-tasks-healthkit-improvements-and-siri-shortcuts/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Focus: The Best Pomodoro App for iPhone, iPad, Apple Watch, and Mac [Sponsor]' href='https://www.macstories.net/sponsored/focus-the-best-pomodoro-app-for-iphone-ipad-apple-watch-and-mac-sponsor/' />
<link rel='next' title='Text Case Adds Siri Shortcut Support for Text Transformations' href='https://www.macstories.net/reviews/text-case-adds-siri-shortcut-support-for-text-transformations/' />
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='https://www.macstories.net/?p=56150' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fstreaks-4-adds-ipad-support-timed-tasks-healthkit-improvements-and-siri-shortcuts%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fstreaks-4-adds-ipad-support-timed-tasks-healthkit-improvements-and-siri-shortcuts%2F&#038;format=xml" />
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.macstories.net/feed/json/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@johnvoorhees">    <meta property="og:description" content="There are a lot of habit trackers on iOS, but Streaks was one of the first and remains the gold standard against which I measure all other trackers. Even as Crunchy Bagel has added new features and customization options, Streaks&rsquo; simple, elegant design has remained at the center of its user experience. That&rsquo;s important because [&hellip;]">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="Streaks 4 Adds iPad Support, Timed Tasks, HealthKit Improvements, and Siri Shortcuts">
    <meta property="og:url" content="https://www.macstories.net/reviews/streaks-4-adds-ipad-support-timed-tasks-healthkit-improvements-and-siri-shortcuts/">
    <meta property="og:image" content="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-17-07-11-43.png">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>
        window.MS_INITIAL_THEME = window.localStorage.theme;

        var _paq = _paq || [];
        /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
        _paq.push(['trackPageView']);
        _paq.push(['enableLinkTracking']);
        (function() {
            var u="//minticci.macstories.net/";
            _paq.push(['setTrackerUrl', u+'piwik.php']);
            _paq.push(['setSiteId', '1']);
            var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
            g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
        })();

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_INITIAL_THEME
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_PUSH_OPTIONS_ARGS = {
            baseURL : 'https://push.macstories.net',
            pushId : 'web.net.macstories.production',
            categories : {
                'News' : 1,
                'Reviews' : 6,
                'Stories' : 7,
                'Linked' : 5129            }
        }

        MS_IFRAMES = [];
        MS_HandleIframeLoad = Array.prototype.push.bind(MS_IFRAMES);
    </script>

</head>

<body class="post-template-default single single-post postid-56150 single-format-standard">
<script>document.body.classList.add(window.MS_INITIAL_THEME)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
        <div><a href='https://masterbuilders.io/promo' target='_blank'><img class='ms-custom-ad' /></a></div><script>document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? 'https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-16-21-39-02.png' : 'https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-16-21-39-22.png'</script>    </div>

    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://appstories.net/">PODCAST</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://club.macstories.net/?utm_source=ms&#038;utm_medium=nav_menu">MEMBERSHIP</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-explore" class="menu dropdown-menu"><li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="https://www.macstories.net/tag/app-store-10/">APP STORE AT 10</a><a class="feed-icon" href="https://www.macstories.net/tag/app-store-10/feed"></a></li>
<li id="menu-item-47663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47663"><a href="https://www.macstories.net/ipad/">IPAD</a><a class="feed-icon" href="https://www.macstories.net/ipad/feed"></a></li>
<li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APPS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
<li id="menu-item-47615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47615"><a href="https://www.macstories.net/tag/automation+ios/">IOS AUTOMATION</a><a class="feed-icon" href="https://www.macstories.net/tag/automation+ios/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <span class='js-theme-trigger action-icon'><svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd"><path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path></g></svg>

</span>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-55658">
    <a class='post-thumbnail' href="https://www.macstories.net/stories/ios-12-the-macstories-review/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-17-13-58-38.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/stories/ios-12-the-macstories-review/" rel="bookmark">iOS 12: The MacStories Review</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-56001">
    <a class='post-thumbnail' href="https://www.macstories.net/news/iphone-xr-xs-and-xs-max-the-macstories-overview/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-13-03-26-40.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/news/iphone-xr-xs-and-xs-max-the-macstories-overview/" rel="bookmark">iPhone XR, XS, and XS Max: The MacStories Overview</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-56007">
    <a class='post-thumbnail' href="https://www.macstories.net/news/apple-watch-series-4-the-macstories-overview/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-13-03-43-32.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/news/apple-watch-series-4-the-macstories-overview/" rel="bookmark">Apple Watch Series 4: The MacStories Overview</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
                    <h3 class="fan-heading">This week's sponsor</h3>
            <div class="fan-text">
                <a class='fan-link' href='https://masterbuilders.io/promo' target='_blank'>Focus</a>
                <div class='fan-description'><p>The Best Pomodoro App for iPhone, iPad, Apple Watch, and Mac</p>
</div>
            </div>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-56150 type-post status-publish format-standard hentry category-reviews tag-fitness tag-health tag-ios-12 tag-productivity tag-shortcuts" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2018-09-17T08:16:22-04:00"></time>            </div>
        
        <h1 class='post-title'>
            Streaks 4 Adds iPad Support, Timed Tasks, HealthKit Improvements, and Siri Shortcuts        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/johnvoorhees/" rel="author">By John Voorhees</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper" id="div1"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-17-07-11-43.png" alt=""></div>
<p id="p2">There are a lot of habit trackers on iOS, but <a href="https://itunes.apple.com/us/app/id963034692?at=11lbfL&amp;ct=linked">Streaks</a> was one of the first and remains the gold standard against which I measure all other trackers. Even as Crunchy Bagel has added new features and customization options, Streaks&rsquo; simple, elegant design has remained at the center of its user experience. That&rsquo;s important because habit tracking only works if it&rsquo;s easy to log events. Even the slightest friction makes it too easy to abandon your efforts.</p>
<p id="p3">I&rsquo;ve <a href="https://www.macstories.net/reviews/achieving-personal-goals-with-streaks/">reviewed Streaks 2</a> and <a href="https://www.macstories.net/reviews/streaks-3-review/">last summer&rsquo;s major 3.0 update</a> before, so I won&rsquo;t cover that ground again here. Instead, I&rsquo;ll focus on what&rsquo;s new: an all-new iPad app, timed tasks, improved health tasks, and Siri shortcuts.</p>
<p id="p4"><span id="more-56150"></span></p>
<h2 id="ipad-app-and-sync">iPad App and Sync</h2>
<div class="media-wrapper" id="div5"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-15-22-46-25.png" alt=""></div>
<p id="p6">Streaks sits at an interesting crossroads where health and fitness apps meet productivity apps. You might use the app to track whether you got eight hours of sleep, how many glasses of water you drank, or how many minutes you spent writing. No matter what habit you want to form, the key is to log it before you forget and move on to another activity. That made Streaks a natural fit for the iPhone and later the Apple Watch, both of which most people have with them all the time.</p>
<p id="p7">With version 4 though, Crunchy Bagel has added iPad support with iCloud sync. The best part of the new iPad version of Streaks is that it works just like the iPhone. Your habits will show up in the same order in both apps and data syncs seamlessly and quickly. Although I haven&rsquo;t found myself logging events on my iPad as often as on my iPhone, I&rsquo;m glad I have the option, especially for tracking activities that I&rsquo;m more likely to do on iPad like reading.</p>
<p id="p8">One option I&rsquo;d like to see added is theme syncing, so the background color of the app is the same on both devices. Those color schemes are a nice way to quickly identify which set of six habits you&rsquo;re viewing, so having them match across devices, just as the custom icons already sync, would be useful.</p>
<h2 id="timed-tasks">Timed Tasks</h2>
<div class="media-wrapper" id="div9"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-17-07-12-12.png" alt=""></div>
<p id="p10">Streaks 4 also adds timed tasks. When you tap the plus button to add a new task, there&rsquo;s a timed task section with five timed task presents:</p>
<ul id="ul11"><li>Read for 10 Minutes</li>
<li>Learn a Language</li>
<li>Practice Instrument </li>
<li>Tidy Up</li>
<li>Mindful Minutes</li>
</ul><p id="p12">You can also create a custom timed action or turn existing tasks into timed ones. Once you set the duration of the task you want to complete and the frequency with which you want to complete it, you&rsquo;re finished. You can set a custom icon if you&rsquo;d like as well. When you return to the main view, you&rsquo;ll see your new timed habit with a play icon overlapping the task&rsquo;s main icon.</p>
<p id="p13">What differentiates timed tasks from others is that they work as a countdown timer. Instead of tapping and holding to increment the times you completed a task, you tap the timed habit&rsquo;s play button, and the time starts counting down. Timers can be started from an iOS device, the Apple Watch, or Streaks&rsquo; Today widget. As time progresses, the band around the task&rsquo;s icon fills with each passing minute. There&rsquo;s no need to keep Streaks open either. When you reach your goal, Steaks notifies you, and the task is marked as completed.</p>
<p id="p14">Adding timers to Streaks is handy because it eliminates the need to use a second app for a time-based task you want to complete regularly. In my tests, the timers worked well on every device, but opening a timer started on one device didn&rsquo;t always show that it was running on a second device, and if it did, the remaining time didn&rsquo;t sync between the two devices. I haven&rsquo;t found myself frequently switching between devices to check running timers, so this hasn&rsquo;t been a major issue, but it&rsquo;s worth keeping in mind.</p>
<h2 id="improved-health-tasks">Improved Health Tasks</h2>
<div class="media-wrapper" id="div15"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-15-22-48-08.png" alt=""></div>
<p id="p16">Since the introduction of HealthKit, Streaks has steadily expanded the ways it works with health and fitness data. With version 4.0, the app has added a handful of new and improved tasks that can be tracked.</p>
<p id="p17">Among the new timed tasks is mindfulness, which syncs with the Health app if the user grants their permission. The Water task, which syncs with the Health app too, can be broken into segments now so you can complete portions of the task throughout the day as you drink glasses of water for instance. There are new nutrition-based tasks that can track things like caffeine and protein intake or help you eat less sugar if you log them in the Health app or use a third-party nutrition app. You can also set a custom bedtime after midnight if your &lsquo;day&rsquo; ends past midnight, like <a href="https://www.macstories.net/author/viticci/">a certain MacStories colleague of mine</a>.</p>
<h2 id="siri-shortcuts">Siri Shortcuts</h2>
<div class="media-wrapper" id="div18"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-15-22-47-03.png" alt=""></div>
<p id="p19">Each of the habits you track in Streaks can be assigned a custom phrase to mark an item as completed or remind you to perform the task. To set up a Siri shortcut, tap the gear icon and then the list icon to access Streaks&rsquo; settings. Under the &lsquo;Hey Siri&rsquo; section of settings, you&rsquo;ll see a list of the habits you&rsquo;ve created. Tap on an activity and you&rsquo;ll find an &lsquo;Add to Siri&rsquo; button that lets you record a custom phrase.</p>
<p id="p20">Siri shortcuts are a significant step forward for Streaks. Whether you have a HomePod, Apple Watch, or iOS device with &lsquo;Hey Siri&rsquo; enabled, it&rsquo;s easier than ever to mark tasks as complete because saying something like &lsquo;Hey Siri, I got a good night&rsquo;s sleep&rsquo; is much more natural than &lsquo;Mark Sleep Eight Hours as complete in Streaks.&rsquo;</p>
<div class="media-wrapper" id="div21"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2018-09-16-08-19-54.png" alt=""></div>
<p id="p22">Of course, the same shortcuts can be integrated into custom shortcuts created in the Shortcuts app too. For example, if you have goals to eat a healthy meal and drink eight glasses of water, and you accomplished both at lunch, you can mark off both goals with a custom shortcut. Just add the Siri shortcuts from Streaks to a single, custom shortcut in the Shortcuts app, then you can trigger it from the app, its widget, or record a custom Siri phrase to mark both goals as completed at the same time.</p>
<hr id="hr23"><p id="p24">Streaks is a great example of where iOS is heading. Apps are no longer single entities that open when you tap an icon on your iPhone&rsquo;s screen. Instead, they permeate the device&rsquo;s system and cross over to other hardware too. Streaks is an app on the iPhone, iPad, and Watch, but it&rsquo;s also a widget and a Siri shortcut that can be activated by voice, appear in search results, on your iPhone&rsquo;s lock screen, or as a suggestion on the Siri watch face.</p>
<p id="p25">Streaks can&rsquo;t change the fact that good habits are hard to form, but by making logging so easy, what it doesn&rsquo;t give you is an excuse to not track your progress. The hard work is on you, but by making logging as accessible as possible, Streaks helps users stay on track by creating a positive feedback loop as they begin to build a streak, see patterns form, and make progress.</p>
<p id="p26">Streaks <a href="https://itunes.apple.com/us/app/id963034692?at=11lbfL&amp;ct=linked">is available on the App Store for $4.99</a>.</p>
            </div>

    
        <footer class='post-footer'>
        <div class="post-tags">Tags: <a href="https://www.macstories.net/tag/fitness/" rel="tag">fitness</a>, <a href="https://www.macstories.net/tag/health/" rel="tag">health</a>, <a href="https://www.macstories.net/tag/ios-12/" rel="tag">iOS 12</a>, <a href="https://www.macstories.net/tag/productivity/" rel="tag">productivity</a>, <a href="https://www.macstories.net/tag/shortcuts/" rel="tag">shortcuts</a></div>        </footer>

        
    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it's also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. Plus, it's made in Italy.</p>
<p>Starting at $5/month, with an annual option available. <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline">Join the Club</a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/5a1475dcd87638ed2f250b6213881115?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/johnvoorhees/" title="Posts by John Voorhees" rel="author">John Voorhees</a></p>
                        <div class='author-bio'><p>John joined MacStories in 2015. He is an editor and regular contributor to MacStories and the <a href="https://club.macstories.net">Club MacStories</a> newsletters, co-hosts <a href="https://appstories.net">AppStories</a>, a weekly podcast exploring the world of apps, with Federico, and handles <a href="https://www.macstories.net/advertise/">sponsorship sales</a> for MacStories and AppStories. John is also the creator of <a href="https://itunes.apple.com/us/app/blink-better-affiliate-links/id946766863?mt=8&amp;at=11lbfL&amp;ct=bio">Blink</a>, an iOS affiliate linking app for the iTunes Affiliate Program.</p>
</div>
        <p class='author-contact-info'>
        <span class='twitter'>Twitter: <a href='https://twitter.com/johnvoorhees' target='_blank'>@johnvoorhees</a></span><span class='separator'> | </span>
        <span class='email'>Email: <a href='mailto:voorhees@macstories.net'>voorhees@macstories.net</a></span>
        </p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-footer" class="menu"><li id="menu-item-54441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54441"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-54439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54439"><a href="https://www.macstories.net/club/">MEMBERSHIP</a></li>
<li id="menu-item-54440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54440"><a href="https://www.macstories.net/advertise/">SPONSORSHIP</a></li>
<li id="menu-item-54438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54438"><a href="https://www.macstories.net/privacy-policy/">PRIVACY POLICY</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='http://pixelcave.net' target='_blank'>Silvia Gatta</a> | Hosted by <a href="https://www.macstadium.com/macstories" target="_blank">MacStadium</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2018 MacStories. All rights reserved.</span>

    <span class='version'>v4.4.3
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201838'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20180525.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20160913.js'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>

</body>
</html>


