<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>Workflow 1.7 Introduces Magic Variables for Easier, More Powerful Visual Automation &#8211;  MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

!function(o){"use strict";var t="b7d8d8403046423987bce7fdbfa25f1d697eea0f",e=function(){var o=document.createElement("style");o.rel="stylesheet",document.head.appendChild(o),o.textContent=localStorage.sourceSansPro};try{var a=!!localStorage.sourceSansPro,n=localStorage.sourceSansProVersion===t;if(a&&n)e();else{var s=function(o){var e="woff";if("FontFace"in o){var a=new o.FontFace("t",'url( "data:application/font-woff2," ) format( "woff2" )',{});a.load()["catch"](function(){}),e="loading"===a.status?"woff2":"woff"}return"https://cdn.rawgit.com/vendruscolo/webfonts/"+t+"/source-sans-pro."+e+".css"}(o),r=new XMLHttpRequest;r.open("GET",s,!0),r.onload=function(){r.status>=200&&r.status<400&&(localStorage.sourceSansProVersion=t,localStorage.sourceSansPro=r.responseText)},r.send()}}catch(c){}}(this);

</script>

<!-- All in One SEO Pack 2.3.9.2 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<meta name="keywords" itemprop="keywords" content="automation,ios,workflow" />

<link rel="canonical" href="https://www.macstories.net/ios/workflow-1-7-introduces-magic-variables-for-easier-more-powerful-visual-automation/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//minticci.macstories.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Turn Touch: A Smart, Flexible Remote Control' href='https://www.macstories.net/news/turn-touch-a-smart-flexible-remote-control/' />
<meta name="generator" content="WordPress 4.6.1" />
<link rel='shortlink' href='https://www.macstories.net/?p=47444' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Fios%2Fworkflow-1-7-introduces-magic-variables-for-easier-more-powerful-visual-automation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Fios%2Fworkflow-1-7-introduces-magic-variables-for-easier-more-powerful-visual-automation%2F&#038;format=xml" />
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@viticci">    <meta property="og:description" content="Magic Variables in Workflow 1.7. At its core, Workflow is a visual programming app that deals with variables. Data flows through actions and is altered by the user until it has to be stored in a variable &ndash; a local reference that can be recalled in subsequent steps. Since the app's original release, the Workflow [&hellip;]">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="Workflow 1.7 Introduces Magic Variables for Easier, More Powerful Visual Automation">
    <meta property="og:url" content="https://www.macstories.net/ios/workflow-1-7-introduces-magic-variables-for-easier-more-powerful-visual-automation/">
    <meta property="og:image" content="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-20-26-10.jpeg">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>
        window.MS_INITIAL_THEME = window.localStorage.theme;

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_INITIAL_THEME
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_PUSH_OPTIONS_ARGS = {
            baseURL : 'https://push.macstories.net',
            pushId : 'web.net.macstories.production',
            categories : {
                'News' : 1,
                'Reviews' : 6,
                'Stories' : 7,
                'Linked' : 5129            }
        }
    </script>

</head>

<body class="single single-post postid-47444 single-format-standard">
<script>document.body.classList.add(window.MS_INITIAL_THEME)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
        <div><a href='' target='_blank'><img class='ms-custom-ad' /></a></div><script>document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? '' : ''</script>    </div>

    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-telegram' href='tg://resolve?domain=MacStories' target='_blank'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="mailto:tips@macstories.net">CONTACT</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://www.macstories.net/club/">NEWSLETTER</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-categories" class="menu dropdown-menu"><li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APP REVIEWS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34521"><a href="https://www.macstories.net/category/linked/">LINKED</a><a class="feed-icon" href="https://www.macstories.net/category/linked/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
<li id="menu-item-35054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35054"><a href="http://www.macstories.net/tag/ios-10">iOS 10</a><a class="feed-icon" href="http://www.macstories.net/tag/ios-10/feed"></a></li>
<li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="http://www.macstories.net/tag/wwdc-2016/">WWDC 2016</a><a class="feed-icon" href="http://www.macstories.net/tag/wwdc-2016/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <span class='action-icon js-theme-trigger' data-event-category='theme' data-event-action='change'>
    <svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg">
        <g fill-rule="evenodd">
            <path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path>
        </g>
    </svg>
</span>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-47407">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/stagehand-review-living-platforms/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-16-02-24.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/stagehand-review-living-platforms/" rel="bookmark">Stagehand Review: Living Platforms</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-47296">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/evernote-8-a-review-and-comparison-with-apple-notes/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-02-17-48-06.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/evernote-8-a-review-and-comparison-with-apple-notes/" rel="bookmark">Evernote 8: A Review and Comparison with Apple Notes</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-47248">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/linea-an-elegant-sketching-app-for-the-ipad-from-the-iconfactory/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-01-13-16-54.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/linea-an-elegant-sketching-app-for-the-ipad-from-the-iconfactory/" rel="bookmark">Linea: An Elegant Sketching App for the iPad from The Iconfactory</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-47444 type-post status-publish format-standard hentry category-ios tag-automation tag-ios tag-workflow" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2017-02-09T16:57:12-05:00"></time>            </div>
        
        <h1 class='post-title'>
            Workflow 1.7 Introduces Magic Variables for Easier, More Powerful Visual Automation        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/viticci/" rel="author">By Federico Viticci</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-20-26-10.jpeg" alt="Magic Variables in Workflow 1.7."><p class="image-caption">Magic Variables in Workflow 1.7.</p></div>
<p>At its core, <a href="https://itunes.apple.com/us/app/workflow-powerful-automation/id915249334?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_inline">Workflow</a> is a visual programming app that deals with variables. Data flows through actions and is altered by the user until it has to be stored in a variable &ndash; a local reference that can be recalled in subsequent steps.</p>
<p>Since the app's <a href="https://www.macstories.net/reviews/workflow-review-integrated-automation-for-ios-8/">original release</a>, the Workflow team has done a commendable job at abstracting the complexity behind variable creation and management, but the feature itself is a vestige of traditional programming languages. The manually-saved variable is fundamentally ill-suited for Workflow's visual approach predicated on direct manipulation of actions. Workflow revolutionized several automation concepts, yet it was always anchored in the common practice of declaring variables between actions.</p>
<p>For the past year, I've been lamenting the sluggishness involved with setting variables and extracting additional details from them. Anyone who's ever created complex workflows has likely come across the same problem:</p>
<ul><li>There's a "master variable" that contains rich metadata (such as an iTunes song or an App Store app);</li>
<li>You want to extract details from the master variable &ndash; e.g. an app's name, icon, or price;</li>
<li>Each of the variable's sub-items has to be extracted by repeating a combination of 'Get Variable-Get Details of Variable-Set Variable' over and over.</li>
</ul><p>Not only did this limitation make workflows slower to create &ndash; it also made variables difficult to explain and workflows harder to read for people who aren't proficient in iOS automation.</p>
<p>As someone who <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=header">writes about iOS workflows on a weekly basis</a>, I've been thinking about this issue for a while. Every time <a href="https://www.relay.fm/canvas/23">I had to explain</a> the inner workings and shortcomings of variables, I kept going back to the same idea: Workflow needed to get rid of its clunky variable management altogether.</p>
<p>Here's <a href="https://www.macstories.net/reviews/workflow-1-5-app-store-automation-trello-and-ulysses-actions-audio-metadata-safari-view-controller-and-more/">what I proposed when Workflow 1.5 launched</a> in May 2016:</p>
<blockquote><p>
  "Instant Variables" to get details of a macro variable without doing the Get Variable-Get Details-Set Variable dance every time. You could save a lot of time if instead of fetching details of a variable multiple times you could use a single master variable and only specify where necessary which sub-details to use;
</p></blockquote>
<p>With today's 1.7 update, the Workflow team isn't introducing Instant Variables. Instead, they've rebuilt the engine behind variables on a new system called <strong>Magic Variables</strong>, which completely reimagines how you can create workflows and connect actions for even more powerful automations.</p>
<p>More than a mere tweak for power users, Magic Variables are the next step in Workflow's goal to enable <em>everyone</em> to automate their iOS devices. By making workflows easier to create and read, Magic Variables are the app's most important transformation to date, and the result far exceeds my expectations.</p>
<p><span id="more-47444"></span></p>
<aside class='aside aligncenter aside-wide'><h2>Workflow Corner on Club MacStories</h2><p>Starting with tomorrow&rsquo;s issue of our newsletter for <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=Workflow17">Club MacStories members</a>, MacStories Weekly, we&rsquo;ll begin sharing workflows built with Magic Variables. You can expect us to dive deep into Magic Variables and advanced use cases for visual automation made possible by Workflow 1.7.</p>
<p>You can <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=Workflow17">learn more about Club MacStories and subscribe here</a>. New members get access to the full archive of every newsletter we&rsquo;ve sent since September 2015.</p>
</aside>
</p><h2 id="its-a-kind-of-magic">It's a Kind of Magic</h2>
<p>Magic Variables <em>mostly</em> remove the need to manually save variables. They leverage <a href="https://www.macstories.net/reviews/workflow-review-integrated-automation-for-ios-8/#the-content-graph">Workflow's Content Graph engine</a> to automatically keep track of variables in the background, allowing you to access them at any time with the ability to change their type (format). It's a novel idea, and it'll take a few minutes to fully grasp, but it's drastically superior to Workflow's old variables. Magic Variables will change how you build workflows.</p>
<p>Each action in Workflow accepts an input and produces an output of a certain type. By default, a 'Text' action generates a string of text, while a screenshot from the photo library generates a PNG image. With Magic Variables, you no longer need to save the output of an action into a named variable. Instead, when you need to use a variable, you can tap a new "magic wand" button above the iOS keyboard to pick the output of <em>any</em> previous action and use it as a variable. Even if you didn't save that action's output into a variable, Workflow now tracks it at runtime to reuse it in other actions later. So, while in the old Workflow you would have had to set and recall variables with this familiar flow...</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-07-04-24-36.jpeg" alt="Manually setting variables in Workflow."><p class="image-caption">Manually setting variables in Workflow.</p></div>
<p>...in Workflow 1.7, you can forget about manually setting variables and let the app take care of it:</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-07-04-25-37.jpeg" alt="The new Magic Variables in Workflow 1.7."><p class="image-caption">The new Magic Variables in Workflow 1.7.</p></div>
<p>The feature may seem more complex than the old system, but Workflow communicates the new functionality with an intuitive design that behaves as you'd expect it to. When you tap the Magic Variable button, the app dims actions and brings up a selection screen where you can scroll the workflow and view action outputs as blue buttons. Here, you can see and understand how action outputs work.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-20-28-39.jpeg" alt="Picking a Magic Variable from the new full-screen editor."><p class="image-caption">Picking a Magic Variable from the new full-screen editor.</p></div>
<p>While in previous versions of Workflow the output of each action would only be passed to the next one and lost if not saved into a variable, Workflow 1.7 remembers every action and its relative output while a workflow is running. Thus, you can tap a blue Magic Variable (which wasn't saved by you) and use it in any other action.</p>
<p>On the surface, this change alone sounds like a sensible addition to the app that can reduce the steps required to remix data and chain actions. But the Workflow team didn't stop at an easier way to pick automatically generated variables.</p>
<p>The true nature of Magic Variables &ndash; what makes them somewhat <em>magical</em> &ndash; lies in how you can transform them without additional actions. The Workflow team has devised a way to change the format of a variable as well as extract its details directly from the variable's UI. Once you see how it works, you wouldn't be able to go back to the old Workflow.</p>
<p>Unlike normal variables, Magic Variables carry the icon of the action that generated them. In addition to being a visual aid, the icon indicates the default type of a Magic Variable: one containing text has a yellow text icon, while a Magic Variable resulting from a 'Search App Store' action carries the App Store's logo next to its name. Tap on a Magic Variable, and you'll open an inline menu where you can alter the type of the variable and pick which of its details to use.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-21-48-33.jpeg" alt="Tap a Magic Variable to edit it and change its type."><p class="image-caption">Tap a Magic Variable to edit it and change its type.</p></div>
<p>If you, like me, spent hours creating workflows that iterated on variables to extract metadata from them with dozens of separate actions, you can imagine why this is a big deal. With Magic Variables, you can specify which parts of a variable you need by selecting them from a built-in menu. Have a master App Store variable but only need the price of an app? Just tell the Magic Variable that you want to extract the 'Formatted Price' sub-item. How about only passing the artist of a song instead of the full item returned from iTunes? Same story: pick the Magic Variable and filter it to only return the Artist.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-21-53-05.jpeg" alt="Changing the type of a Magic Variable from Safari webpage to Article."><p class="image-caption">Changing the type of a Magic Variable from Safari webpage to Article.</p></div>
<p>Variable details are indicated with a darker shade of blue in the same variable token, and they can be reverted at any time to the original state of the Magic Variable.</p>
<p>Visually, the difference between how you used to parse variables and Workflow 1.7 is striking:</p>
<div class="media-wrapper"><a href="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-21-55-53.jpeg"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-21-55-53.jpeg" alt="Workflow 1.7 (right) doesn't need to use multiple 'Get Details of Variable' actions."></a><p class="image-caption">Workflow 1.7 (right) doesn't need to use multiple 'Get Details of Variable' actions.</p></div>
<p>When I was considering the possibility of easier sub-variable creation in Workflow last year, this is exactly the kind of system I had in mind. Rather than requiring you to navigate through multiple stages of extracting variable details, Magic Variables make metadata an <em>option</em> that is clearly presented in the interface. Thanks to this, workflows are easier to manage; what used to be a series of 10+ actions can be summarized in a single collection of Magic Variables.</p>
<p>There's more, though. Magic Variables can be renamed: in the editor, tap on the 'Rename' button and you'll be able to assign the variable a unique name to be reflected throughout a workflow. Every time you open the Magic Variable editor, you'll see the custom name you assigned.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-21-58-42.jpeg" alt="Magic Variables that have been assigned custom names."><p class="image-caption">Magic Variables that have been assigned custom names.</p></div>
<p>The combination of icons, custom names, and inline variable details goes a long way towards making workflows more readable &ndash; something that couldn't be said for the generic look of variables and the repetition of 'Get Variable-Get Details of Variable' action pairs in the old Workflow.</p>
<p>Once you start adapting your workflows to Magic Variables, you'll also notice that it's easy to lose track of what each action does when there's no more 'Set Variable' step to act as a descriptive label.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-09-03-32-53.jpeg" alt="The Reveal button highlights the actions associated with a Magic Variable."><p class="image-caption">The Reveal button highlights the actions associated with a Magic Variable.</p></div>
<p>Fortunately, next to Rename, there's a Reveal button that scrolls to the action that generated the currently selected Magic Variable.<sup id="fnref-47444-1"><a href="#fn-47444-1" rel="footnote">1</a></sup> This makes it easy to jump back and forth between a Magic Variable and the original action behind it, which helps when debugging long workflows.<sup id="fnref-47444-2"><a href="#fn-47444-2" rel="footnote">2</a></sup></p>
<p>The other notable trait of Magic Variables is how they represent Workflow's Content Graph engine through one-tap type coercion.</p>
<p>Let's back up a bit first. Since Workflow 1.0, one of the app's greatest assets has been its engine &ndash; the Content Graph &ndash; that intelligently converts data between formats to avoid errors in workflows as much as possible. Normally, for instance, you would think that passing an image to a Text action would generate an error; with the Content Graph's type coercion, Workflow assumes that an image passed as text means the user wants to extract the file name of the image. It's with this system that Workflow is able to turn URLs into PDFs of a webpage, Maps links into JPEGs, or an App Store result into an app icon saved into your photo library. Workflow constantly assumes what the user's intention might be in case it hasn't been stated with specific actions.</p>
<p>With Magic Variables, conversion between data formats reaches its logical conclusion as a visual picker embedded within the Type menu of a variable. Upon tapping a Magic Variable, you'll see the type that Workflow loaded for it by default as a blue button under the variable's name. You can tap this button to open a list of types and dynamically change the nature of the variable without the need to execute other actions.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-03-25.jpeg" alt="Converting Magic Variables between different types."><p class="image-caption">Converting Magic Variables between different types.</p></div>
<p>One-tap type conversion opens intriguing possibilities for automation. The reduction of "processor" actions to change types<sup id="fnref-47444-3"><a href="#fn-47444-3" rel="footnote">3</a></sup> increases the flexibility of variables, which in turn should enable deeper customization of actions. By putting the spotlight on type conversion, Magic Variables highlight the foundation of Workflow's engine with unparalleled clarity.</p>
<p>Magic Variables have cut my most complex workflows in half. They allowed me to focus on the functionality of each action rather than remembering to save its output for later. While advanced chains of actions were possible before Workflow 1.7, Magic Variables make everything faster and easier to create, as well as <em>nicer</em> to look at.</p>
<p>Magic Variables are the best change to happen to Workflow since launch; I've prepared a few examples to explain why.</p>
<h2 id="working-with-magic-variables">Working with Magic Variables</h2>
<p>Alongside Magic Variables, Workflow 1.7 introduces new ways to pick variables and enter them in action fields. From a new variable bar that sits above the keyboard, you can access the Magic Variable editor, open a grid of variables, but also scroll a row of dynamic variable suggestions as well as shortcuts for "quick inputs" such as the clipboard, the current date<sup id="fnref-47444-4"><a href="#fn-47444-4" rel="footnote">4</a></sup>, and the 'Ask When Run' dialog.</p>
<p>The variable bar isn't just a prettier way to pick variables for actions. Workflow will also contextually suggest Magic Variables depending on which action is currently being edited. If you're entering a variable in a 'Text' action placed after a 'Choose from Menu' item, the end result of the menu will be suggested as a Magic Variable; when adding a reminder that follows a choice to pick a photo from the library, a 'Photos' Magic Variable will be displayed as a shortcut in the variable bar.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-05-15.jpeg" alt="The new variable suggestion bar in Workflow 1.7."><p class="image-caption">The new variable suggestion bar in Workflow 1.7.</p></div>
<p>In my experience, Workflow 1.7 has correctly predicted which variables I wanted to use based on previous actions. It's a small tweak, but it adds to the time savings of this update. Combined with the app's existing list of suggested actions, it's never been easier to get started making workflows.</p>
<p>My favorite example of the power of Magic Variables is my updated workflow to turn articles from Safari into templates for linked posts in a text editor.</p>
<p>I use this workflow on a daily basis: whenever I find a story I want to link on MacStories, I select some text on the original webpage and run the workflow. In a couple of seconds, I end up with a post template in <a href="https://itunes.apple.com/us/app/ulysses/id950335311?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_inline">Ulysses</a> containing Markdown text as well as the original's author name. There's no manual copy &amp; paste and I never type the author's name wrong because it's automatically extracted by Workflow.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-07-04.jpeg" alt=""></div>
<p>Thanks to Magic Variables, this workflow has been cut down to 6 actions. The majority of the work happens in a 'Text' action where three Magic Variables perform the following data manipulation:</p>
<ol><li>A URL is converted into the title of the webpage through variable detail extraction;</li>
<li>Using type conversion, the input of the action extension<sup id="fnref-47444-5"><a href="#fn-47444-5" rel="footnote">5</a></sup> is first converted from 'Safari webpage' to 'Article' and then the author's name (a variable detail) is extracted;</li>
<li>The output of 'Make Markdown from Rich Text' is referenced as a Magic Variable.</li>
</ol><p>The benefit of Magic Variables is apparent in this workflow. Instead of having to micro-manage outputs with a stream of 'Set Variable' and 'Get Details of Variable' actions, I can just throw in actions and recall their outputs later in an interface that also lets me change their type and fetch details I need. This workflow was possible before (I've been using it for almost a year now), but it's never been this short or readable. You can <a href="https://workflow.is/workflows/60837befa9cb440880297637fddbb2d2">get the workflow here</a>.</p>
<p>The versatility of Magic Variable details and variable suggestions is most impressive in the workflow I use to save an App Store result as a "rich app card" in Trello. This is the workflow I use whenever I find an app or iMessage sticker pack I want to link <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=header">in our newsletter</a>: with a couple of taps, I can go from an App Store product page to a card in Trello other team members can see.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-12-55.jpeg" alt="From an App Store app to a rich Trello card."><p class="image-caption">From an App Store app to a rich Trello card.</p></div>
<p>This workflow, however, was quite long before Workflow 1.7 &ndash; 28 actions, mostly comprised of 'Get Variable-Get Details of App Store App' iterations used to extract the app details required to create a card in Trello.</p>
<p>With Magic Variables, I was able to go from <strong>28 actions to 14</strong> actions while retaining the same functionality and achieving a clearer presentation of the workflow. Most of the heavy-lifting is now handled by a single Magic Variable in the 'Add Trello Card' action: the same variable is repeated multiple times in the description field of the card, each time with a different variable detail. This way, what used to be 9 actions (3 for each variable detail) is now 3 Magic Variables that don't require any action at all.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-14-50.jpeg" alt="Old actions (left) can now be built using Magic Variables."><p class="image-caption">Old actions (left) can now be built using Magic Variables.</p></div>
<p>Combined with the Magic Variable for the output of the If block and the lack of 'Set Variable' actions, these changes led to the removal of 14 actions, cutting the length of the workflow in half while preserving all of its functionality. You can <a href="https://workflow.is/workflows/ab0063c13a7742a1a171f1092d5d74ed">get the workflow here</a>.</p>
<p>I've observed similar savings in my workflow to save a currently playing song in a playlist and send it to my girlfriend over iMessage. This workflow used to contain 15 actions that extracted song details (name, artist, and iTunes URL) before adding the song to a playlist and preparing an iMessage.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-08-22-17-19.jpeg" alt=""></div>
<p>Now, the same workflow requires 7 actions thanks to Magic Variables. Song details I want to send in an iMessage are assembled in a 'Text' action; they're the result of a 'Search iTunes Store' action that returns 10 songs, which are then passed to a 'Choose from List' step. The song picked in the list is still an iTunes-type product, which means Magic Variables can extract details about the song from it. You can <a href="https://workflow.is/workflows/8a262215708645ccb7d15f2df74ff922">get the workflow here</a>.</p>
<p>I'm in the process of updating all my workflows for Magic Variables, and a trend is clear: along with fewer actions per workflow, the role of the 'Set Variable' action is changing.</p>
<p>Despite Magic Variables, it is still possible to set variables and use them as you've always done. However, the use cases for manually setting variables are now extremely limited. The only instance where I can imagine users might want to have a named variable is for workflows where a variable of the same name changes across non-contiguous blocks of actions.</p>
<p>Between Magic Variables and suggestions for outputs of Repeat and If blocks, I effectively see the 'Set Variable' action as deprecated in Workflow 1.7. It's still around and it can be used in workflows, but Magic Variables are the future.</p>
<hr><p>There are some implementation details of Magic Variables I would have liked to see done differently.</p>
<p>Some action fields (like Trello's Attachments one) don't let you tap on a Magic Variable to extract details. I assume this is due to how certain fields in Workflow already open a popup to pick variables when tapped (it's the same deal with the Category field in the 'Search iTunes Store' action, for instance), but this shouldn't have been the case. The inability to fully use Magic Variables in <em>some</em> fields adds inconsistency to the app. Every field of every action should support the full range of Magic Variable editing.</p>
<p>While it's remarkable that Magic Variables can convert types and perform advanced operations such as extracting a specific value from a dictionary<sup id="fnref-47444-6"><a href="#fn-47444-6" rel="footnote">6</a></sup>, these built-in controls haven't been brought to other variable types that would benefit from them. You can't restrict a regular expression match to a specific capturing group from a Magic Variable, for example, and you can't fetch an indexed item from a list unless you use a separate action. In future updates to the app, I hope we'll get additional options for type conversion and detail extracting in other formats.</p>
<p>Finally, with an easier way to convert variables between types as well as fetch details of a variable, it's become clear that Workflow needs a 'Generate Collection' action to combine multiple variables together and pass them to another action.</p>
<div class="media-wrapper"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-02-09-03-35-06.jpeg" alt="There should be an easier way to do this."><p class="image-caption">There should be an easier way to do this.</p></div>
<p>Think about it: if you want to combine a string of text and an image in a single variable, how would you do that? You'd have to iterate over multiple bits of content and use the 'Add to Variable' action, which is still the only way to create collections of items with different types. A 'Generate Collection' action with an empty field would make it possible to bundle multiple Magic Variables together, enabling shorter workflows that, for example, send an email message containing text and images or tweets with messages and video attachments. This isn't a problem per se, but it's a byproduct of the new flexibility enabled by Magic Variables.</p>
<h2 id="a-new-workflow">A New Workflow</h2>
<p>I often ponder what the Workflow team should address in the app's journey towards version 2.0. Magic Variables are precisely the enhancement that Workflow needed to move past the boundaries of classic programming environments; they rejuvenate Workflow's creative side by simplifying an essential aspect of visual coding such as variable management. After trying them, it's obvious that Magic Variables make more sense than anything that came before.</p>
<p>Magic Variables couldn't exist in traditional scripting languages; they are only possible thanks to Workflow's unique approach to visual automation.</p>
<p>Looking back at the past year in Workflow's release cycle, it's impressive to witness how much this team has accomplished. With <a href="https://www.macstories.net/reviews/workflow-1-5-app-store-automation-trello-and-ulysses-actions-audio-metadata-safari-view-controller-and-more/">App Store automation</a>, integration with <a href="https://www.macstories.net/ios/workflow-update-brings-ability-to-interact-with-any-web-api/">web APIs</a>, better <a href="https://www.macstories.net/news/workflow-1-6-brings-revamped-gallery-better-tools-to-share-and-import-workflows/">community and sharing tools</a>, and now a complete overhaul of variables, Workflow is a profoundly different app from the one that <a href="https://www.macstories.net/reviews/workflow-review-integrated-automation-for-ios-8/">launched in December 2014</a>. At this point, lack of folders and other organizational features is the next big thing the Workflow team should tackle.</p>
<p>Magic Variables make Workflow feel like a new app altogether. They're a fantastic addition to iOS automation and I look forward to updating years of workflows for Magic Variables.</p>
<p>Workflow 1.7 is <a href="https://itunes.apple.com/us/app/workflow-powerful-automation/id915249334?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_inline">available on the App Store</a>.</p>
<div class="footnotes">
<hr><ol><li id="fn-47444-1">
Doing so will highlight an action with a delightful drop shadow, which the Workflow team is bringing back in style throughout the app. Several UI elements of Workflow now carry borders, depth, and shadows &ndash; I like it.&nbsp;<a href="#fnref-47444-1" rev="footnote">&#8617;&#65038;</a>
</li>
<li id="fn-47444-2">
To mark up other actions visually, I recommend using the 'Comment' action to add descriptions inline. You'll thank me later.&nbsp;<a href="#fnref-47444-2" rev="footnote">&#8617;&#65038;</a>
</li>
<li id="fn-47444-3">
Routines that span 5+ actions can now be cut down to <strong>one Magic Variable</strong>.&nbsp;<a href="#fnref-47444-3" rev="footnote">&#8617;&#65038;</a>
</li>
<li id="fn-47444-4">
The date variable entered from the keyboard can be adjusted like any other Magic Variable: you can tap to change the format for date and time within the variable. This removes the need to use two separate actions ('Date' and 'Format Date') to achieve the same functionality.&nbsp;<a href="#fnref-47444-4" rev="footnote">&#8617;&#65038;</a>
</li>
<li id="fn-47444-5">
Another default Magic Variable in Workflow 1.7.&nbsp;<a href="#fnref-47444-5" rev="footnote">&#8617;&#65038;</a>
</li>
<li id="fn-47444-6">
Which makes working with web APIs in Workflow downright amazing now.&nbsp;<a href="#fnref-47444-6" rev="footnote">&#8617;&#65038;</a>
</li>
</ol></div>
            </div>

    
        <footer class='post-footer'>
        <div class="post-tags">Tags: <a href="https://www.macstories.net/tag/automation/" rel="tag">automation</a>, <a href="https://www.macstories.net/tag/ios/" rel="tag">iOS</a>, <a href="https://www.macstories.net/tag/workflow/" rel="tag">workflow</a></div>        </footer>

    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it&rsquo;s also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. Plus, it&rsquo;s made in Italy.</p>
<p>Starting at $5/month, with an annual option available. <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline">Join the Club</a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/94a9aa7c70dbeb9440c6759bd2cebc2a?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/viticci/" title="Posts by Federico Viticci" rel="author">Federico Viticci</a></p>
                        <div class='author-bio'><p>Federico is the founder and editor-in-chief of MacStories, where he writes about Apple with a focus on apps, developers, and mobile software. He can also be found on his three podcasts &ndash; <a href="http://www.relay.fm/connected">Connected</a>, <a href="https://www.relay.fm/canvas">Canvas</a>, and <a href="http://www.relay.fm/remaster">Remaster</a>.</p>
</div>
        <p class='author-contact-info'>
<span class='twitter'>Twitter: <a href='http://twitter.com/viticci' target='_blank'>@viticci</a></span><span class='separator'> | </span><span class='email'>Email: <a href='mailto:viticci@macstories.net'>viticci@macstories.net</a></span></p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-pages-1" class="menu js-push-menu-target"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="mailto:tips@macstories.net">CONTACT</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://www.macstories.net/club/">NEWSLETTER</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-telegram' href='tg://resolve?domain=MacStories' target='_blank'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='http://pixelcave.net' target='_blank'>Silvia Gatta</a> | Hosted by <a href="http://www.macminicolo.net/macstories" target="_blank">Macminicolo</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2017 MacStories. All rights reserved.</span>

    <span class='version'>v4.3.5
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20160913.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20160913.js'></script>
<script type='text/javascript' async src='https://minticci.macstories.net/?js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>

</body>
</html>


