<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>Ulysses 12: Writing on iOS Has Never Been Better &#8211;  MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

!function(o){"use strict";var t="b7d8d8403046423987bce7fdbfa25f1d697eea0f",e=function(){var o=document.createElement("style");o.rel="stylesheet",document.head.appendChild(o),o.textContent=localStorage.sourceSansPro};try{var a=!!localStorage.sourceSansPro,n=localStorage.sourceSansProVersion===t;if(a&&n)e();else{var s=function(o){var e="woff";if("FontFace"in o){var a=new o.FontFace("t",'url( "data:application/font-woff2," ) format( "woff2" )',{});a.load()["catch"](function(){}),e="loading"===a.status?"woff2":"woff"}return"https://cdn.rawgit.com/vendruscolo/webfonts/"+t+"/source-sans-pro."+e+".css"}(o),r=new XMLHttpRequest;r.open("GET",s,!0),r.onload=function(){r.status>=200&&r.status<400&&(localStorage.sourceSansProVersion=t,localStorage.sourceSansPro=r.responseText)},r.send()}}catch(c){}}(this);

</script>

<!-- All in One SEO Pack 2.4 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<meta name="keywords"  content="text editor" />

<link rel="canonical" href="https://www.macstories.net/reviews/ulysses-12-writing-on-ios-has-never-been-better/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//minticci.macstories.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='AppStories, Episode 27 – Music Services and Apps' href='https://www.macstories.net/news/appstories-episode-27-music-services-and-apps/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='https://www.macstories.net/?p=51466' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fulysses-12-writing-on-ios-has-never-been-better%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fulysses-12-writing-on-ios-has-never-been-better%2F&#038;format=xml" />
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.macstories.net/feed/json/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'>
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@iryantldr">    <meta property="og:description" content="This summer Ulysses announced a major business model shift, with its iOS and macOS apps moving from up front purchases to subscription supported. As tends to happen, the move stirred up some controversy. In my mind at least, the company&rsquo;s reasoning was sound &ndash; as the app&rsquo;s co-founder stated, &ldquo;Writers want to rely on a [&hellip;]">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="Ulysses 12: Writing on iOS Has Never Been Better">
    <meta property="og:url" content="https://www.macstories.net/reviews/ulysses-12-writing-on-ios-has-never-been-better/">
    <meta property="og:image" content="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-13-20-02.jpeg">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>
        window.MS_INITIAL_THEME = window.localStorage.theme;

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_INITIAL_THEME
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_PUSH_OPTIONS_ARGS = {
            baseURL : 'https://push.macstories.net',
            pushId : 'web.net.macstories.production',
            categories : {
                'News' : 1,
                'Reviews' : 6,
                'Stories' : 7,
                'Linked' : 5129            }
        }

        MS_IFRAMES = [];
        MS_HandleIframeLoad = Array.prototype.push.bind(MS_IFRAMES);
    </script>

</head>

<body class="post-template-default single single-post postid-51466 single-format-standard">
<script>document.body.classList.add(window.MS_INITIAL_THEME)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
        <div><a href='http://bal.money/macstories' target='_blank'><img class='ms-custom-ad' /></a></div><script>document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? 'https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/macstories-desktop-banner-2x_11506356998412.png' : 'https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/macstories-desktop-banner-2x_11506356998412-21508171389584.png'</script>    </div>

    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-telegram' href='tg://resolve?domain=MacStories' target='_blank'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://appstories.net/">PODCAST</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://www.macstories.net/club/">NEWSLETTER</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-categories" class="menu dropdown-menu"><li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APP REVIEWS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="https://www.macstories.net/tag/ipad-diaries/">IPAD DIARIES</a><a class="feed-icon" href="https://www.macstories.net/tag/ipad-diaries/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
<li id="menu-item-47614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47614"><a href="https://www.macstories.net/tag/ios-11/">IOS 11</a><a class="feed-icon" href="https://www.macstories.net/tag/ios-11/feed"></a></li>
<li id="menu-item-47615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47615"><a href="https://www.macstories.net/tag/automation+ios/">IOS AUTOMATION</a><a class="feed-icon" href="https://www.macstories.net/tag/automation+ios/feed"></a></li>
<li id="menu-item-47663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47663"><a href="https://www.macstories.net/tag/games,game-day,game/">GAMES</a><a class="feed-icon" href="https://www.macstories.net/tag/games,game-day,game/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <span class='js-theme-trigger action-icon'><svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd"><path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path></g></svg>

</span>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-50922">
    <a class='post-thumbnail' href="https://www.macstories.net/stories/watchos-4-review/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-09-21-02-48-33.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/stories/watchos-4-review/" rel="bookmark">watchOS 4: The MacStories Review</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-50886">
    <a class='post-thumbnail' href="https://www.macstories.net/stories/ios-11-the-macstories-review/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-09-20-04-37-23.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/stories/ios-11-the-macstories-review/" rel="bookmark">iOS 11: The MacStories Review</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-50728">
    <a class='post-thumbnail' href="https://www.macstories.net/news/iphone-8-and-iphone-x-the-macstories-overview/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-09-14-18-23-01.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/news/iphone-8-and-iphone-x-the-macstories-overview/" rel="bookmark">iPhone 8 and iPhone X: The MacStories Overview</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
                    <h3 class="fan-heading">This week's sponsor</h3>
            <div class="fan-text">
                <a class='fan-link' href='http://bal.money/macstories' target='_blank'>Balance</a>
                <div class='fan-description'><p>A wallet for all the worlds currencies and tokens.</p>
</div>
            </div>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-51466 type-post status-publish format-standard hentry category-reviews tag-text-editor" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2017-10-19T11:07:02-04:00"></time>            </div>
        
        <h1 class='post-title'>
            Ulysses 12: Writing on iOS Has Never Been Better        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/ryanchristoffel/" rel="author">By Ryan Christoffel</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper" id="div1"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-13-20-02.jpeg" alt=""></div>
<p id="p2">This summer Ulysses announced <a href="https://www.macstories.net/news/ulysses-announces-move-to-subscription-pricing/">a major business model shift</a>, with its <a href="https://itunes.apple.com/us/app/ulysses/id1225571038?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_ryan">iOS</a> and <a href="https://itunes.apple.com/us/app/ulysses/id1225570693?mt=12&amp;uo=4&amp;at=10l6nh&amp;ct=ms_ryan">macOS</a> apps moving from up front purchases to subscription supported. As tends to happen, the move stirred up some controversy. In my mind at least, the company&rsquo;s reasoning was sound &ndash; <a href="https://medium.com/building-ulysses/why-were-switching-ulysses-to-subscription-47f80b07a9cd">as the app&rsquo;s co-founder stated</a>, &ldquo;Writers want to rely on a professional tool that is constantly evolving, and we want to keep delivering just that.&rdquo;</p>
<p id="p3">Today brings the first major update to Ulysses following its switch to subscriptions. Bolstered by Apple&rsquo;s recent focus on evolving the iPad platform, Ulysses 12 is primarily an iOS release; while the Mac version gains some improvements, it clearly isn&rsquo;t the centerpiece here. Ulysses on iOS gains drag and drop support, multi-pane editing, streamlined library navigation, and image previews &ndash; all of which make an already powerful writing tool even better.</p>
<p id="p4"><span id="more-51466"></span></p>
<h2 id="drag-and-drop">Drag and Drop</h2>
<p id="p5">Drag and drop support is found in two main places in Ulysses: the sheet list and editor. The former enables quick, easy reorganization of existing sheets. You can pick up one or more sheets from the sheet list and drop them into a separate group. As you&rsquo;re navigating the app to find the destination group, holding your drag contents over a group will spring-load it open. Drag and drop also makes it easy to reorder sheets within their current group when manual sorting is selected &ndash; this only works with one sheet at a time, however. And the nice bonus with all these sheet list tricks is that they work both on iPad and iPhone.</p>
<div class="media-wrapper" id="div6"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-12-57-10.jpeg" alt=""></div>
<p id="p7">The iPhone also benefits from some of the editor&rsquo;s drag and drop powers. On both iPhone and iPad, you can pick up text or images from a sheet and do one of three things with that lifted content: you can drop it inside its source sheet to move it within the sheet, drop it into a separate sheet to copy it there, or drop it into a sheet list to create a new sheet containing a copy of that content.</p>
<p id="p8">These in-app drag and drop features are thoughtful and thorough. As has been demonstrated by the iPhone-only <a href="https://www.macstories.net/reviews/castros-latest-update-transforms-podcast-organization/">Castro</a>, drag and drop can be transformative even when limited to a single app. <a href="https://www.macstories.net/reviews/omnifocus-for-ios-11-adds-extensive-drag-and-drop-and-siri-support/">OmniFocus</a> is another great example &ndash; even though it supports cross-app drag and drop, its in-app execution improves the task management experience in significant ways. The best thing about Ulysses treading a similar path is that the drag and drop actions you&rsquo;d take on iPad work exactly the same on iPhone. No, you can&rsquo;t take content out of the app like on iPad, but while working in the Ulysses app itself, your experience will be the same regardless of iOS device &ndash; a key benefit that shouldn&rsquo;t be undervalued.</p>
<div class="media-wrapper" id="div9"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-12-59-54.jpeg" alt=""></div>
<p id="p10">Aside from everything I&rsquo;ve mentioned, Ulysses on iPad of course takes full advantage of the platform&rsquo;s drag and drop privileges. Text and images can be dragged out of Ulysses or dropped into it. You can even drop text or images directly into the editor&rsquo;s sidebar as attachments. My favorite application of cross-app drag and drop is dragging a portion of text from Safari into Ulysses &ndash; the selected text is seamlessly imported, and in most cases it&rsquo;s converted automatically to the appropriate Markdown formatting, leaving no cleanup work for me to do.</p>
<p id="p11"><a href="https://ulyssesapp.com/blog/2017/09/coming-up/">Ulysses has promised</a> that future updates will bring drag and drop to more areas of the app, such as export, but this doesn&rsquo;t feel at all like a mere first take on drag and drop &ndash; if nothing more ever arrived, I&rsquo;d still be content.</p>
<h2 id="multi-pane-editing">Multi-Pane Editing</h2>
<div class="media-wrapper" id="div12"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-13-03-46.jpeg" alt=""></div>
<p id="p13">For as long as I&rsquo;ve used Ulysses on iPad, there has always been one annoying limitation I&rsquo;ve wished would change: the inability to edit sheets while viewing your sheet list or library. Particularly because I work on a 12.9&rdquo; iPad Pro, seeing the app&rsquo;s various panes shift back and forth as I worked in each one, even though there was plenty of screen real estate to have everything stay on-screen at once, grew taxing. Ulysses 12 fixes this issue in a big way: now you can simultaneously view and work in as many panes as will comfortably fit on your screen. For me and my giant iPad, this means I can view the library, sheet list, and body of a sheet all at once &ndash; even while typing away.</p>
<p id="p14">Navigating different views in Ulysses is done with the simple swipe gesture found in prior versions of the app. This is a marked improvement over methods employed in Apple&rsquo;s Notes and Mail, which require you to hit certain buttons to change views. It all works fluidly in Ulysses.</p>
<h2 id="image-previews">Image Previews</h2>
<p id="p15">Historically, one of my favorite Ulysses features has been the way I can add Markdown links without needing to see the full syntax. That philosophy has always extended to inline images as well, but not in the way most users would want &ndash; image syntax has been hidden, but the image itself has been hidden too, behind a tag labeled &lsquo;IMG&rsquo;. This approach has made it impossible to view your images while doing the work of writing. I&rsquo;ve grown used to regularly hitting the export button to see a WordPress publishing preview of my full post, images and all. But now, for many use cases at least, Ulysses provides image previews inline.</p>
<div class="media-wrapper" id="div16"><img src="https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2017-10-18-13-08-26.jpeg" alt=""></div>
<p id="p17">Image previews are meant to provide proper context without serving as a distraction while you&rsquo;re writing, so they&rsquo;re tailored to fit in best with the current theme you&rsquo;re using &ndash; in the body of your sheet, colors in images are muted in a way that complements your theme&rsquo;s accent colors. If you want to view the original image, you can do that by viewing the full image details; additionally, the size of image previews can be set from the Layout screen in Ulysses&rsquo; Settings menu.</p>
<p id="p18">If you add images to Ulysses using drag and drop or by adding from another app like Photos or Files, image previews will work great for you. Unfortunately, the way we handle images at MacStories prevents me from getting this benefit. We upload all images for the site to our CDN, then enter links to uploaded images in the body of our stories. Because the images aren&rsquo;t actually stored directly in Ulysses, but are mere links, images for me continue to bear the &lsquo;IMG&rsquo; tag inline with no actual preview.</p>
<h2 id="miscellany">Miscellany</h2>
<p id="p19"><strong>Library</strong>: Like on the Mac, Ulysses&rsquo; library now contains all possible sources in one place, including iCloud, On My iPad/iPhone, and Dropbox. You can easily collapse and expand these, or disable the ones you don&rsquo;t use in settings.</p>
<p id="p20"><strong>Design</strong>: Ulysses has implemented iOS 11&rsquo;s trademark large titles, and also includes revised icons in several places throughout the app; I&rsquo;m especially fond of the new icons, which provide greater clarity as to what actions they represent. Also, a sheet&rsquo;s word count is now constantly visible, located at the bottom of the screen in a small, subtle grey font.</p>
<p id="p21"><strong>Mac Improvements</strong>: The Mac version of Ulysses gains image previews like its iOS companion, but besides that any new user-facing features are limited. The Ulysses team says the Mac version has received substantial performance improvements, but I never write on a Mac anymore, so I can&rsquo;t adequately comment on those.</p>
<p id="p22"></p><hr id="hr23"><p id="p24">In early 2016 <a href="https://www.macstories.net/reviews/review-ulysses-2-5-for-ipad-and-now-iphone/">Ulysses proved</a> that professional-level writing could be as great on iOS as it is on the Mac. Particularly on the iPad this rang true, but even the then-new iPhone edition of Ulysses was surprisingly good. Since that time the app has continued to evolve, making an already top-class writing experience even better.</p>
<p id="p25">I use Ulysses every day. Aside from a brief stint with <a href="https://itunes.apple.com/us/app/bear/id1016366447?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_weekly">Bear</a>, it&rsquo;s been my writing app of choice for over eighteen months now, during which time it&rsquo;s proven itself the most capable, reliable, elegant tool to aid my work.</p>
<p id="p26">With its first major release after the switch to subscriptions, Ulysses proves that it&rsquo;s still the best solution for me, and that it likely will be for a long while still. Drag and drop is a welcome addition, but it&rsquo;s all the other changes and refinements that make this release truly special &ndash; my few small nitpicks with the app have almost all been taken care of in version 12.</p>
<p id="p27">Every user will have their own needs and preferences, but for my writing, I wouldn&rsquo;t want to be without Ulysses.</p>
<p id="p28">Ulysses is available on both <a href="https://itunes.apple.com/us/app/ulysses/id1225571038?mt=8&amp;uo=4&amp;at=10l6nh&amp;ct=ms_ryan">iOS</a> and <a href="https://itunes.apple.com/us/app/ulysses/id1225570693?mt=12&amp;uo=4&amp;at=10l6nh&amp;ct=ms_ryan">macOS</a>.</p>
            </div>

    
        <footer class='post-footer'>
        <div class="post-tags">Tags: <a href="https://www.macstories.net/tag/text-editor/" rel="tag">text editor</a></div>        </footer>

    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it's also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. Plus, it's made in Italy.</p>
<p>Starting at $5/month, with an annual option available. <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline">Join the Club</a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/6f92854b21cbef25629d7efb809a9de7?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/ryanchristoffel/" title="Posts by Ryan Christoffel" rel="author">Ryan Christoffel</a></p>
                        <div class='author-bio'><p>Ryan is a regular contributor to MacStories. He most commonly works and plays on his iPad Pro and bears no regrets about moving on from the Mac. He and his wife live in Texas, where he works for his church.</p>
</div>
        <p class='author-contact-info'>
<span class='twitter'>Twitter: <a href='http://twitter.com/iryantldr' target='_blank'>@iryantldr</a></span><span class='separator'> | </span><span class='email'>Email: <a href='mailto:ryan@macstories.net'>ryan@macstories.net</a></span></p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-pages-1" class="menu js-push-menu-target"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://appstories.net/">PODCAST</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://www.macstories.net/club/">NEWSLETTER</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-telegram' href='tg://resolve?domain=MacStories' target='_blank'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='http://pixelcave.net' target='_blank'>Silvia Gatta</a> | Hosted by <a href="https://www.macstadium.com/macstories" target="_blank">MacStadium</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2017 MacStories. All rights reserved.</span>

    <span class='version'>v4.4.1
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201742'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20170918.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20160913.js'></script>
<script type='text/javascript' async src='https://minticci.macstories.net/?js'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>

</body>
</html>



<!-- Dynamic page generated in 0.384 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-10-20 11:15:28 -->

<!-- super cache -->