<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>HoudahSpot 5 Review: Advanced File Search and Filtering on the Mac &#8211;  MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

!function(o){"use strict";var t="b7d8d8403046423987bce7fdbfa25f1d697eea0f",e=function(){var o=document.createElement("style");o.rel="stylesheet",document.head.appendChild(o),o.textContent=localStorage.sourceSansPro};try{var a=!!localStorage.sourceSansPro,n=localStorage.sourceSansProVersion===t;if(a&&n)e();else{var s=function(o){var e="woff";if("FontFace"in o){var a=new o.FontFace("t",'url( "data:application/font-woff2," ) format( "woff2" )',{});a.load()["catch"](function(){}),e="loading"===a.status?"woff2":"woff"}return"https://cdn.rawgit.com/vendruscolo/webfonts/"+t+"/source-sans-pro."+e+".css"}(o),r=new XMLHttpRequest;r.open("GET",s,!0),r.onload=function(){r.status>=200&&r.status<400&&(localStorage.sourceSansProVersion=t,localStorage.sourceSansPro=r.responseText)},r.send()}}catch(c){}}(this);

</script>

<!-- All in One SEO Pack 2.4.3.1 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="canonical" href="https://www.macstories.net/news/houdahspot-5-review-advanced-file-search-and-filtering-on-the-mac/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Arq: Trustworthy Backup [Sponsor]' href='https://www.macstories.net/sponsored/arq-trustworthy-backup-sponsor/' />
<link rel='next' title='Pixelmator Photo: The MacStories Review' href='https://www.macstories.net/reviews/pixelmator-photo-the-macstories-review/' />
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='https://www.macstories.net/?p=58805' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Fnews%2Fhoudahspot-5-review-advanced-file-search-and-filtering-on-the-mac%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Fnews%2Fhoudahspot-5-review-advanced-file-search-and-filtering-on-the-mac%2F&#038;format=xml" />
<link rel="alternate" type="application/json" title="MacStories &raquo; JSON Feed" href="https://www.macstories.net/feed/json/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@johnvoorhees">    <meta property="og:description" content="There's a lot of power lurking under the hood of the Mac&rsquo;s Spotlight search index, but that&rsquo;s also the trouble. To make Spotlight accessible to more users, many of the feature&rsquo;s most useful tools are hidden behind menus and special search syntax. HoudahSpot takes a different approach that makes it easier to access the power [&hellip;]">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="HoudahSpot 5 Review: Advanced File Search and Filtering on the Mac">
    <meta property="og:url" content="https://www.macstories.net/news/houdahspot-5-review-advanced-file-search-and-filtering-on-the-mac/">
    <meta property="og:image" content="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/houdahspot-screenshot-41554668737977.png">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>

        window.MS_THEME_KEY_LIGHT = 'theme-light';
        window.MS_THEME_KEY_DARK = 'theme-dark';
        window.MS_THEME_KEY_AUTO = 'theme-auto';
        window.MS_THEME_MEDIA_QUERY_DARK = window.matchMedia('(prefers-color-scheme: dark)');
        window.MS_THEME_MEDIA_QUERY_LIGHT = window.matchMedia('(prefers-color-scheme: light)');
        window.MS_THEME_KEY_FROM_COLOR_SCHEME_PREFERENCE = function () {
            if (window.MS_THEME_MEDIA_QUERY_DARK.matches) {
                return window.MS_THEME_KEY_DARK;
            }

            return window.MS_THEME_KEY_LIGHT;
        }
        window.MS_THEME_INITIAL_SETTING = window.MS_THEME_INITIAL = window.localStorage.themeV2 || window.localStorage.theme || window.MS_THEME_KEY_AUTO;
        if (window.MS_THEME_INITIAL_SETTING === window.MS_THEME_KEY_AUTO) {
            window.MS_THEME_INITIAL = window.MS_THEME_KEY_FROM_COLOR_SCHEME_PREFERENCE();
        }

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_THEME_INITIAL_SETTING
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_PUSH_OPTIONS_ARGS = {
            baseURL : 'https://push.macstories.net',
            pushId : 'web.net.macstories.production',
            categories : {
                'News' : 1,
                'Reviews' : 6,
                'Stories' : 7,
                'Linked' : 5129            }
        }

        MS_IFRAMES = [];
        MS_HandleIframeLoad = Array.prototype.push.bind(MS_IFRAMES);
    </script>

</head>

<body class="post-template-default single single-post postid-58805 single-format-standard">
<script>document.body.classList.add(window.MS_THEME_INITIAL)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
        <div><a href='https://www.arqbackup.com/features/?utm_source=banner&utm_medium=macstories&utm_campaign=april2019' target='_blank'><img class='ms-custom-ad' /></a></div><script>document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? 'https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/banner_desktop1554722654217.png' : 'https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/banner_mobile1554722598998.png'</script>    </div>

    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://www.macstories.net/shortcuts/">SHORTCUTS</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://club.macstories.net/?utm_source=ms&#038;utm_medium=nav_menu">MEMBERSHIP</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-explore" class="menu dropdown-menu"><li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="https://www.macstories.net/tag/app-store-10/">APP STORE AT 10</a><a class="feed-icon" href="https://www.macstories.net/tag/app-store-10/feed"></a></li>
<li id="menu-item-47663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47663"><a href="https://www.macstories.net/ipad/">IPAD</a><a class="feed-icon" href="https://www.macstories.net/ipad/feed"></a></li>
<li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APPS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
<li id="menu-item-47615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47615"><a href="https://www.macstories.net/tag/automation+ios/">IOS AUTOMATION</a><a class="feed-icon" href="https://www.macstories.net/tag/automation+ios/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <div class='js-dropdown-container dropdown-menu-container categories'>
    <div class='dropdown-menu-trigger'>
        <span class='dropdown-menu-placeholder'><span class='action-icon'><svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd"><path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path></g></svg>

</span></span>
        <span class='dropdown-menu-arrow'></span>
    </div>
    <nav role='navigation'>
        <ul class='menu dropdown-menu dropdown-menu-theme-selector'>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-dark'><a href='#'>DARK</a></li>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-light'><a href='#'>LIGHT</a></li>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-auto'><a href='#'>AUTOMATIC</a></li>
        </ul>
    </nav>
</div>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-58818">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/pixelmator-photo-the-macstories-review/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-04-09-21-21-17.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/pixelmator-photo-the-macstories-review/" rel="bookmark">Pixelmator Photo: The MacStories Review</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-58676">
    <a class='post-thumbnail' href="https://www.macstories.net/stories/new-airpods-first-impressions-wireless-magic/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-03-27-17-40-59.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/stories/new-airpods-first-impressions-wireless-magic/" rel="bookmark">New AirPods First Impressions: Wireless Magic</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-58613">
    <a class='post-thumbnail' href="https://www.macstories.net/news/apple-announces-apple-news-service-for-magazines-our-overview-and-first-impressions/">
        <div class='post-thumbnail-image' style='background-image: url("https://2672686a4cf38e8c2458-2712e00ea34e3076747650c92426bbb5.ssl.cf1.rackcdn.com/2019-03-25-22-34-52.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/news/apple-announces-apple-news-service-for-magazines-our-overview-and-first-impressions/" rel="bookmark">Apple Announces Apple News+ Service for Magazines: Our Overview and First Impressions</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
                    <h3 class="fan-heading">This week's sponsor</h3>
            <div class="fan-text">
                <a class='fan-link' href='https://www.arqbackup.com/features/?utm_source=banner&utm_medium=macstories&utm_campaign=april2019' target='_blank'>Arq</a>
                <div class='fan-description'><p>Trustworthy Backup</p>
</div>
            </div>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-58805 type-post status-publish format-standard hentry category-news" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2019-04-08T11:10:03-04:00"></time>            </div>
        
        <h1 class='post-title'>
            HoudahSpot 5 Review: Advanced File Search and Filtering on the Mac        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/johnvoorhees/" rel="author">By John Voorhees</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper" id="div1"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/houdahspot-screenshot-41554668737977.png" alt=""></div>
<p id="p2">There's a lot of power lurking under the hood of the Mac&rsquo;s Spotlight search index, but that&rsquo;s also the trouble. To make Spotlight accessible to more users, many of the feature&rsquo;s most useful tools are hidden behind menus and special search syntax.</p>
<p id="p3"><a href="https://www.houdah.com/houdahSpot/">HoudahSpot</a> takes a different approach that makes it easier to access the power of Spotlight. The app surfaces Spotlight&rsquo;s advanced file search functionality and couples it with its own layer of tools to extend what Spotlight can do. With version 5, the app has been reexamined from top to bottom adding new features and refining the entire experience. The result is a terrific update that maintains HoudahSpot&rsquo;s position as one of the premier pro utilities on the Mac.</p>
<p id="p4"><span id="more-58805"></span></p>
<p id="p5">The risk of surfacing the complexities of Spotlight is producing an app that is frustrating and difficult to use. HoudahSpot avoids that problem by using a familiar multi-pane window approach that provides a sensible flow through the search process.</p>
<div class="media-wrapper" id="div6"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/houdahspot-screenshot-11554668857306.png" alt=""></div>
<p id="p7">The process of finding a file with HoudahSpot mirrors how searches start for most people. Usually, that begins with a recollection of something about a file; whether that&rsquo;s a bit of text from the file name, the contents of the file, or something else. In that case, you do just as you would in your browser. Type the text you are looking for into HoudahSpot&rsquo;s search field and hit the Return key or click the play button next to the search field. That kicks off a search that remains active until you click the stop button. HoudahSpot&rsquo;s search field also supports several advanced search operators like predefined relative dates such as &lsquo;next week&rsquo; and &lsquo;yesterday&rsquo; as well as wildcard characters, boolean operators, numeric values, comparisons, ranges, and more. Additional searches can be started in a separate window or new tab.</p>
<p id="p8">If you find what you were looking for immediately, you probably didn&rsquo;t need HoudahSpot to find it. The app is most useful when your first rudimentary search turns up hundreds or thousands of files in HoudahSpot&rsquo;s results pane, which is when its search parameters come into play.</p>
<p id="p9">Below HoudahSpot&rsquo;s toolbar, up to four panels can be displayed. The far left panel is where templates, snippets, and favorite tags live, which I&rsquo;ll cover later in this review.</p>
<p id="p10">The next panel of HoudahSpot&rsquo;s window is where searches are refined. There are more options for refining a search than make sense to list in this review. In total, there are around 200 different parameters you can use to refine a search from common ones like &lsquo;File Extension&rsquo; to obscure ones like &lsquo;dSYM UUIDs.&rsquo; HoudahSpot doesn&rsquo;t overwhelm users with every choice though. Name, Kind, Tags, Last Opened, Created, Modified, File Extension, Text Content, and others are all available from a drop-down menu in the Refine pane. The rest are available by choosing &lsquo;Other&rsquo; and browsing the full list of filter parameters.</p>
<div class="media-wrapper" id="div11"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/screenshot-2019-04-07-15-02-531554668970758.png" alt="Refining a search with HoudahSpot's hundreds of search parameters." title="Refining a search with HoudahSpot's hundreds of search parameters."><p class="image-caption">Refining a search with HoudahSpot's hundreds of search parameters.</p></div>
<p id="p12">For each search parameter you pick, the search can be further refined with qualifiers that depend on the kind of parameter you are searching. For example, a Text Content parameter can be limited to &lsquo;contains prefixes,&rsquo; &lsquo;contains words,&rsquo; &lsquo;contains phrase,&rsquo; and &lsquo;contains all.&rsquo; Search parameters can also be grouped, allowing you to pick a series of parameters and require that &lsquo;All,&rsquo; &lsquo;Any,&rsquo; or &lsquo;None&rsquo; of them be true.</p>
<p id="p13">As you build a search, rows can be disabled temporarily to test alternative setups without deleting them, which is a great way to experiment with how a new row affects search results. Right-clicking a row provides several options to nest or duplicate lines, add snippets, save lines as snippets, and more. The flexibility is impressive and allows for rapid iteration of search formulations.</p>
<p id="p14">Searches can be refined by location too. You can choose any drive or volume on your Mac as well as user-mounted remote volumes or exclude locations, which is a fantastic option when you want to search a top-level folder, but for example, you know the results from a large subfolder can be safely excluded. HoudahSpot also allows you to set minimum and maximum limits on the number of results returned based on how recently the files were created, opened, or modified.</p>
<p id="p15">Once you begin searching for files, your search results remain live, updating as you add filters automatically, until you click the stop button. This allows for an iterative process with immediate feedback. Instead of running variants of a search over and over, your search benefits from a tight, frictionless feedback loop in the results pane, reducing frustration when you don&rsquo;t find what you're looking for at first.</p>
<h2 id="saved-searches-templates-snippets-and-tags">Saved Searches, Templates, Snippets, and Tags</h2>
<p id="p16">HoudahSpot assumes that most searches are transient and not something you want to save, so it doesn&rsquo;t do so automatically. However, searches can be saved as separate HoudahSpot documents that open in the app and execute the saved search. That strikes me as the right approach. Most often, I&rsquo;m merely looking for a particular file that I&rsquo;ve lost track of on my Mac and don't need to repeat the search later.</p>
<p id="p17">That&rsquo;s not to say, however, that you have to start from scratch with every search you conduct in HoudahSpot. Besides saving searches, you can create Templates and Snippets. Templates are similar to saved searches that serve as re-usable recipes for finding a particular category of files.</p>
<div class="media-wrapper" id="div18"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/screenshot-2019-04-07-15-04-321554669062062.png" alt="The Misplaced Music Files Template." title="The Misplaced Music Files Template."><p class="image-caption">The Misplaced Music Files Template.</p></div>
<p id="p19">HoudahSpot comes with several built-in Templates that help illustrate the concept. For example, &lsquo;Misplaced Music Files&rsquo; looks for audio files with certain metadata characteristics that are outside your Mac&rsquo;s Music folder. There&rsquo;s another template that finds files that have been tagged using the Finder&rsquo;s tagging system. You can use these templates and ones you save yourself as complete searches that you run over and over or as starting points that you can modify.</p>
<p id="p20">Snippets are a little different. A snippet is a self-contained series of steps that are useful in a variety of different searches. For instance, the &lsquo;Date Created range&rsquo; snippet consists of a &lsquo;Content Created after&rsquo; and a &lsquo;Content Created before&rsquo; parameter, both of which must be true. Instead of reimplementing these rules over and over every time you need a date range, you can add the snippet to the search you&rsquo;re building, saving some time.</p>
<div class="media-wrapper" id="div21"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/screenshot-2019-04-07-15-05-521554669141957.png" alt="A 'Date Created range' Snippet." title="A 'Date Created range' Snippet."><p class="image-caption">A 'Date Created range' Snippet.</p></div>
<p id="p22">The left-hand panel also houses your favorite file tags. If tagging&rsquo;s your thing, dragging a favorite tag into the Refine panel is a quick way to narrow your results.</p>
<h2 id="search-results">Search Results</h2>
<p id="p23">HoudahSpot&rsquo;s utility isn&rsquo;t limited to how you set up searches. The results panel includes additional functionality for finding what you need. Results can be displayed as a list or grid. There&rsquo;s also a fourth panel on the far right that can be opened to preview a file&rsquo;s contents and metadata. When previewing the contents of a text file HoudahSpot zeroes in on the parts that contain your search terms, making it easy to quickly identify if you&rsquo;ve found what you&rsquo;re looking for. To see more, there&rsquo;s an &lsquo;Unfold&rsquo; command in the View menu, which displays the file&rsquo;s full contents.</p>
<div class="media-wrapper" id="div24"><img src="https://bddf794624247cea6a0b-b4761d2ba0154d0278c36dbf2b3c114d.ssl.cf1.rackcdn.com/screenshot-2019-04-07-15-07-351554669288148.png" alt="HoudahSpot displays extensive metadata about files." title="HoudahSpot displays extensive metadata about files."><p class="image-caption">HoudahSpot displays extensive metadata about files.</p></div>
<p id="p25">Results can be arranged by app, date added, created, last used, and modified, file size, and total size. In Grid view, you can turn on additional file information which will display information like an image&rsquo;s size, f-stop, shutter speed, ISO, and other metadata directly below the file name. The info panel on the right side of the window can also be moved, so it appears beneath the list of results to conserve horizontal space.</p>
<p id="p26">The files displayed in the results pane can be filtered in several ways too. Using the search field at the top of the results, you can filter or exclude files based on their name, path, file name, folder name, and folder name in path. The filters you apply can be as simple as a string of text or as complex as a regular expression.</p>
<p id="p27">HoudahSpot&rsquo;s view options and filters are an essential final step in finding a file, especially if after refining your search, you still have a large number of files to sift through.</p>
<h2 id="all-the-rest">All the Rest</h2>
<p id="p28">There are lots of other features big and small that make HoudahSpot a premier power user tool. One of my favorites is compact mode. With the click of a button in the app&rsquo;s toolbar, HoudahSpot&rsquo;s window and chrome shrink down to a compact size. Once you&rsquo;ve found the files for which you&rsquo;re looking, compact mode is a fantastic way to help arrange your windows that makes dragging files into another app or folder easier.</p>
<p id="p29">HoudahSpot also includes a Finder extension that sits in the Finder&rsquo;s toolbar and a Quick Action available in the Finder&rsquo;s sidebar. It&rsquo;s a little thing, but if you&rsquo;re working in the Finder and can&rsquo;t find the right files, the ability to quickly open HoudahSpot with its extension to access its more powerful tools is helpful. I wish, however, that HoudahSpot could grab any search you&rsquo;ve started in the Finder and make that the starting point of your HoudahSpot search, but it doesn&rsquo;t do that. However, HoudahSpot will open a new search window restricted to the folder being viewed when the extension or Quick Action is clicked.</p>
<p id="p30">HoudahSpot supports Mojave&rsquo;s Dark Mode as well as the Touch Bar, from which you can do things like start and stop a search, preview files, sort and tag results, and share files. Keyboard shortcuts are available for tagging and summoning HoudahSpot&rsquo;s templates. If you enable the HoudahSpot menu bar app, you can also set keyboard shortcuts to open the app, open the search bar that also appears when you click on the menu bar app, and to search the currently-active Finder window.</p>
<p id="p31">Automation is available throughout HoudahSpot too. There are Alfred and LaunchBar actions to trigger searches from those apps. There&rsquo;s also a PopClip extension that can be used to start a HoudahSpot search for any text you highlight. There are macOS Services for starting searches, AppleScript support for starting new searches and conducting searches based on the active Finder window, and a URL scheme for integrating HoudahSpot searches in other apps that support them.</p>
<hr id="hr32"><p id="p33">There is a lot of power and complexity right under the surface of HoudahSpot&rsquo;s simple interface, but what I appreciate most about the app is that, although its power-user tools are always close at hand, the app works just as well with a simple search. That has the benefit of making it easy to start with what seems like a simple search then bring HoudahSpot&rsquo;s more advanced tools to bear when your search turns out to be something more demanding. Its scalability means you don&rsquo;t need to reserve HoudahSpot for those times when you know you&rsquo;ve got a tough file to find. Instead, the app can be used as a complete replacement for searching for files via Spotlight or the Finder&rsquo;s search field.</p>
<p id="p34">I've been using HoudahSpot 5 for a few months now, and it has steadily taken over more and more of my file search needs. I still go straight to the Finder to access well-organized, favorite folders that I keep in the sidebar, but for everything else, I usually start with a custom Alfred search workflow that <a href="alfred://customsearch/HoudahSpot/houdah/utf8/nospace/houdahspot4%3A%2F%2Fsearch%3Fq%3D%7Bquery%7D">you can download here</a>.</p>
<p id="p35">Once you learn some of HoudahSpot's search syntax, Alfred searches such as <code>kind:mp3 author:turner</code>, which returns every MP3 on my Mac by <a href="https://itunes.apple.com/us/artist/frank-turner/108696785">Frank Turner</a>, are incredibly useful. Spotlight would return the same MP3s using my example search, but only the five most recently-opened files. In contrast, if my search returns a lot of results, my Alfred workflow has already opened HoudahSpot, so I can immediately access its tools  to refine my search and filter results. I've found that the years-old habit of searching from inside the Finder is hard to break, but if you find yourself frustrated when you formulate more complex searches, I highly recommend giving HoudahSpot a try. The time I've invested in learning the app and retraining myself have been well worth the effort.</p>
<p id="p36">HoudahSpot <a href="https://www.houdah.com/houdahSpot/">is available directly from Houdah Software</a> for $34 for a single license and $52 for a family license that includes everyone living in the same household. The app also offers a free trial.</p>
            </div>

    
        <footer class='post-footer'>
                </footer>

        
    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it's also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. Plus, it's made in Italy.</p>
<p>Starting at $5/month, with an annual option available. <a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline">Join the Club</a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/5a1475dcd87638ed2f250b6213881115?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/johnvoorhees/" title="Posts by John Voorhees" rel="author">John Voorhees</a></p>
                        <div class='author-bio'><p>John joined MacStories in 2015. He is an editor and regular contributor to MacStories and the <a href="https://club.macstories.net">Club MacStories</a> newsletters, co-hosts <a href="https://appstories.net">AppStories</a>, a weekly podcast exploring the world of apps, with Federico, and handles <a href="https://www.macstories.net/advertise/">sponsorship sales</a> for MacStories and AppStories. John is also the creator of <a href="https://itunes.apple.com/us/app/blink-better-affiliate-links/id946766863?mt=8&amp;at=11lbfL&amp;ct=bio">Blink</a>, an iOS affiliate linking app for the iTunes Affiliate Program.</p>
</div>
        <p class='author-contact-info'>
        <span class='twitter'>Twitter: <a href='https://twitter.com/johnvoorhees' target='_blank'>@johnvoorhees</a></span><span class='separator'> | </span>
        <span class='email'>Email: <a href='mailto:voorhees@macstories.net'>voorhees@macstories.net</a></span>
        </p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-footer" class="menu"><li id="menu-item-54441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54441"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-54439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54439"><a href="https://www.macstories.net/club/">MEMBERSHIP</a></li>
<li id="menu-item-54440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54440"><a href="https://www.macstories.net/advertise/">SPONSORSHIP</a></li>
<li id="menu-item-54438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54438"><a href="https://www.macstories.net/privacy-policy/">PRIVACY POLICY</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='http://pixelcave.net' target='_blank'>Silvia Gatta</a> | Hosted by <a href="https://www.macstadium.com/macstories" target="_blank">MacStadium</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2019 MacStories. All rights reserved.</span>

    <span class='version'>v4.4.6
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201915'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20190406.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20160913.js'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>

</body>
</html>


