<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset='UTF-8'>
    <meta name='viewport' content='width=device-width, initial-scale=1, minimum-scale=1'>
    <title>Puppr Review: Teach Your Dog New Tricks - MacStories</title>

    <style media='screen' type='text/css'>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</style>
<script>

</script>

<!-- All in One SEO Pack 3.3.5 by Michael Torbert of Semper Fi Web Design[164,219] -->

<meta name="keywords"  content="education,ios,utility" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.macstories.net/#organization","url":"https://www.macstories.net/","name":"MacStories","sameAs":[]},{"@type":"WebSite","@id":"https://www.macstories.net/#website","url":"https://www.macstories.net/","name":"MacStories","publisher":{"@id":"https://www.macstories.net/#organization"}},{"@type":"WebPage","@id":"https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/#webpage","url":"https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/","inLanguage":"en-US","name":"Puppr Review: Teach Your Dog New Tricks","isPartOf":{"@id":"https://www.macstories.net/#website"},"datePublished":"2021-01-11T21:53:37-05:00","dateModified":"2021-01-11T21:53:37-05:00"},{"@type":"Article","@id":"https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/#article","isPartOf":{"@id":"https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/#webpage"},"author":{"@id":"https://www.macstories.net/author/alexguyot/#author"},"headline":"Puppr Review: Teach Your Dog New Tricks","datePublished":"2021-01-11T21:53:37-05:00","dateModified":"2021-01-11T21:53:37-05:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/#webpage"},"publisher":{"@id":"https://www.macstories.net/#organization"},"articleSection":"reviews, education, iOS, utility"},{"@type":"Person","@id":"https://www.macstories.net/author/alexguyot/#author","name":"Alex Guyot","sameAs":["_alexguyot"],"image":{"@type":"ImageObject","@id":"https://www.macstories.net/#personlogo","url":"https://secure.gravatar.com/avatar/f0541d67822e4e8ab166f2856d05588f?s=96&d=mm&r=g","width":96,"height":96,"caption":"Alex Guyot"}}]}</script>
<link rel="canonical" href="https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.macstories.net/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.macstories.net/app/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.macstories.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.macstories.net/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.macstories.net/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Apple and Others Suspend Parler from Their Platforms' href='https://www.macstories.net/news/apple-and-others-suspend-parler-from-their-platforms/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.macstories.net/?p=65687' />
<link rel="alternate" type="application/json+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fpuppr-review-teach-your-dog-new-tricks%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.macstories.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.macstories.net%2Freviews%2Fpuppr-review-teach-your-dog-new-tricks%2F&#038;format=xml" />
<link rel="alternate" type="application/feed+json" title="MacStories &raquo; JSON Feed" href="https://www.macstories.net/feed/json/" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel='alternate' type='application/rss+xml' title='MacStories' href='https://www.macstories.net/feed/' /><link rel='alternate' type='application/rss+xml' title='MacStories — Articles Only' href='https://www.macstories.net/?feed=articles-only' />    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@macstoriesnet">        <meta name="twitter:creator" content="@_alexguyot">    <meta property="og:description" content="I came across Puppr during its recent feature as Apple’s App of the Day and decided to give it a try. The app is a simple and fun instructional tool for teaching your dog new behaviors and tricks. Since I’ve been staying with my parents for the last couple of months, I decided to take">
    <meta property="og:locale" content="en_US">
    <meta property="og:title" content="Puppr Review: Teach Your Dog New Tricks">
    <meta property="og:url" content="https://www.macstories.net/reviews/puppr-review-teach-your-dog-new-tricks/">
    <meta property="og:image" content="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610396427912.png">
    <meta property="og:type" content="article"><link rel='apple-touch-icon' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='152x152' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-152x152-precomposed.png'><link rel='apple-touch-icon' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='120x120' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-120x120-precomposed.png'><link rel='apple-touch-icon' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon-precomposed' sizes='76x76' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-76x76-precomposed.png'><link rel='apple-touch-icon' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='apple-touch-icon-precomposed' href='https://www.macstories.net/app/themes/macstories4/images/apple-touch-icon-precomposed.png'><link rel='mask-icon' sizes='any' href='https://www.macstories.net/app/themes/macstories4/images/logo-shape-black.svg' color='#b00a0f'><link rel='icon' type='image/png' href='https://www.macstories.net/app/themes/macstories4/images/favicon.png'>
    <link rel='profile' href='http://gmpg.org/xfn/11'>
    <link rel='pingback' href='https://www.macstories.net/wp/xmlrpc.php'>

    <script>

        window.MS_THEME_KEY_LIGHT = 'theme-light';
        window.MS_THEME_KEY_DARK = 'theme-dark';
        window.MS_THEME_KEY_AUTO = 'theme-auto';
        window.MS_THEME_MEDIA_QUERY_DARK = window.matchMedia('(prefers-color-scheme: dark)');
        window.MS_THEME_MEDIA_QUERY_LIGHT = window.matchMedia('(prefers-color-scheme: light)');
        window.MS_THEME_KEY_FROM_COLOR_SCHEME_PREFERENCE = function () {
            if (window.MS_THEME_MEDIA_QUERY_DARK.matches) {
                return window.MS_THEME_KEY_DARK;
            }

            return window.MS_THEME_KEY_LIGHT;
        }
        window.MS_THEME_INITIAL_SETTING = window.MS_THEME_INITIAL = window.localStorage.themeV2 || window.localStorage.theme || window.MS_THEME_KEY_AUTO;
        if (window.MS_THEME_INITIAL_SETTING === window.MS_THEME_KEY_AUTO) {
            window.MS_THEME_INITIAL = window.MS_THEME_KEY_FROM_COLOR_SCHEME_PREFERENCE();
        }

        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create', 'UA-8004705-2', 'auto');
        ga('set', {
            dimension1: window.MS_THEME_INITIAL_SETTING
        });
        ga('require', 'displayfeatures');
        ga('require', 'eventTracker');
        ga('require', 'outboundLinkTracker');
        ga('send', 'pageview');

        MS_IFRAMES = [];
        MS_HandleIframeLoad = Array.prototype.push.bind(MS_IFRAMES);
    </script>

</head>

<body class="post-template-default single single-post postid-65687 single-format-standard">
<script>document.body.classList.add(window.MS_THEME_INITIAL)</script>

<header class='site-main-header' role='banner'>

    <div class='ad-container'>
    <div>
        <a href='http://www.bzgapps.com/macstories' target='_blank' rel='noopener noreferrer'><img class='ms-custom-ad' /></a>
    </div>
    <script>
        document.querySelector('.ms-custom-ad').src = window.innerWidth >= 728 ? 'https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Unite%204%20banner%20desktop-1610305179366.png' : 'https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Unite%204%20banner%20mobile-1610305179308.png'
    </script>
</div>


    <div class='logo-follow-container'>
        <a class='logo' href='https://www.macstories.net/' rel='home'>
            <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo.svg' alt='MacStories' />
        </a>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

            <div class='club'>
            <a class='club-target' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=header'><span class='club-gold'>Club MacStories</span><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories' /><span class='club-red'>Weekly Extras</span></a>        </div>
    
    <div class='main-menu js-search-target'>

        <div class='main-menu-container js-dropdown-menus'>

            <div class='js-dropdown-container dropdown-menu-container about'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>MENU</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-pages" class="menu dropdown-menu"><li id="menu-item-34518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34518"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-34517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34517"><a href="https://www.macstories.net/advertise/">ADVERTISE</a></li>
<li id="menu-item-40502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40502"><a href="https://www.macstories.net/shortcuts/">SHORTCUTS</a></li>
<li id="menu-item-34519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34519"><a href="https://www.macstories.net/pixel/">PIXEL</a></li>
</ul>                </nav>
            </div>

            <div class='js-dropdown-container dropdown-menu-container categories'>
                <div class='dropdown-menu-trigger'>
                    <span class='dropdown-menu-placeholder'>SECTIONS</span>
                    <span class='dropdown-menu-arrow'></span>
                </div>
                <nav role='navigation'>
                    <ul id="menu-explore" class="menu dropdown-menu"><li id="menu-item-47615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47615"><a href="https://www.macstories.net/tag/ios-14/">iOS 14</a><a class="feed-icon" href="https://www.macstories.net/tag/ios-14/feed"></a></li>
<li id="menu-item-34523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34523"><a href="https://macstories.net/pixel/">PIXEL</a><a class="feed-icon" href="https://macstories.net/pixel/feed"></a></li>
<li id="menu-item-47663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47663"><a href="https://www.macstories.net/ipad/">IPAD</a><a class="feed-icon" href="https://www.macstories.net/ipad/feed"></a></li>
<li id="menu-item-34520" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34520"><a href="https://www.macstories.net/category/reviews/">APPS</a><a class="feed-icon" href="https://www.macstories.net/category/reviews/feed"></a></li>
<li id="menu-item-34522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34522"><a href="https://www.macstories.net/category/stories/">STORIES</a><a class="feed-icon" href="https://www.macstories.net/category/stories/feed"></a></li>
</ul>                </nav>
            </div>

            <div class='menu-separator'></div>

            <div class='actions-container'>

                <div class='js-dropdown-container dropdown-menu-container categories'>
    <div class='dropdown-menu-trigger'>
        <span class='dropdown-menu-placeholder'><span class='action-icon'><svg width="20px" height="20px" viewBox="0 0 20 20" version="1.1" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd"><path d="M10,2 C14.418278,2 18,5.581722 18,10 C18,14.418278 14.418278,18 10,18 L10,2 Z M10,20 C15.5228475,20 20,15.5228475 20,10 C20,4.4771525 15.5228475,0 10,0 C4.4771525,0 0,4.4771525 0,10 C0,15.5228475 4.4771525,20 10,20 Z"></path></g></svg>

</span></span>
        <span class='dropdown-menu-arrow'></span>
    </div>
    <nav role='navigation'>
        <ul class='menu dropdown-menu dropdown-menu-theme-selector'>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-dark'><a href='#'>DARK</a></li>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-light'><a href='#'>LIGHT</a></li>
            <li class='menu-item menu-item-theme js-theme-trigger' data-theme-key='theme-auto'><a href='#'>AUTOMATIC</a></li>
        </ul>
    </nav>
</div>
                <span class='action-icon js-search-trigger'>
                    <svg width="22px" height="22px" viewBox="0 0 22 22" version="1.1" xmlns="http://www.w3.org/2000/svg">
                        <g fill-rule="evenodd">
                            <path d="M13.4234148,15.4297524 L19.448,21.5445135 C19.7266667,21.8481712 20.1226667,22 20.504,22 C20.8853333,22 21.2666667,21.8481712 21.56,21.5445135 C22.1466667,20.9371981 22.1466667,19.9503106 21.56,19.3429952 L15.4330727,13.4187466 C16.4198155,12.0304247 17,10.332967 17,8.5 C17,3.80557963 13.1944204,0 8.5,0 C3.80557963,0 0,3.80557963 0,8.5 C0,13.1944204 3.80557963,17 8.5,17 C10.3350219,17 12.0342305,16.4185138 13.4234148,15.4297524 Z M8.5,15 C12.0898509,15 15,12.0898509 15,8.5 C15,4.91014913 12.0898509,2 8.5,2 C4.91014913,2 2,4.91014913 2,8.5 C2,12.0898509 4.91014913,15 8.5,15 Z"></path>
                        </g>
                    </svg>
                </span>

                    <form role="search" method="get" class="search-form " action="https://www.macstories.net/">
        <input class="search-field" type="search" placeholder="Search..." value="" name="s" title="Search for" />
    </form>            </div>

        </div>
    </div>

</header>

<div class='featured-posts'>

    
    <div class='featured-posts-scroller js-featured-posts-slider'>

        <div class='featured-posts-container'>

            <article class='featured-post js-scrolled-item' id="post-65651">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/two-months-with-the-homepod-mini-more-than-meets-the-eye/">
        <div class='post-thumbnail-image' style='background-image: url("https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/studio-1609953213970-1610289264503.jpeg")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/two-months-with-the-homepod-mini-more-than-meets-the-eye/" rel="bookmark">Two Months with the HomePod mini: More Than Meets the Eye</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-65626">
    <a class='post-thumbnail' href="https://www.macstories.net/reviews/dato-review-calendar-events-and-time-zones-from-your-macs-menu-bar/">
        <div class='post-thumbnail-image' style='background-image: url("https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/PNG%20image-E627AB60FEA3-1-1609519578283-1609768719316.png")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/reviews/dato-review-calendar-events-and-time-zones-from-your-macs-menu-bar/" rel="bookmark">Dato Review: Calendar Events and Time Zones From Your Mac&#8217;s Menu Bar</a></h1>
</article>

<article class='featured-post js-scrolled-item' id="post-65580">
    <a class='post-thumbnail' href="https://www.macstories.net/ios/wallcreator-2-0-adds-ability-to-set-wallpapers-save-and-restore-favorites-plus-automation-support/">
        <div class='post-thumbnail-image' style='background-image: url("https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/iVBORw0KGgoAAAANSUhEUgAAC50AAAjwCAYAAAAKgq9xAAAACXBIWXMAAAsTAAALEwEAmpwYAAAM-1608218692813-1608225186255.png")'></div>
    </a>

    <h1 class="post-title"><a class="post-link" href="https://www.macstories.net/ios/wallcreator-2-0-adds-ability-to-set-wallpapers-save-and-restore-favorites-plus-automation-support/" rel="bookmark">WallCreator 2.0 Adds Ability to Set Wallpapers, Save and Restore Favorites, Plus Automation Support</a></h1>
</article>


        </div>

    </div>

    <div class='dots-container js-featured-posts-dots'>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
                    <div class='dot js-dot'></div>
            </div>

</div>
<div class='fan-of-the-week'>
    <div class='fan-of-the-week-container'>
                    <h3 class="fan-heading">THIS WEEK'S SPONSOR:</h3>
            <div class="fan-text">
                <a class='fan-link' href='http://www.bzgapps.com/macstories' target='_blank' rel='noopener noreferrer'>Unite 4</a>
                <div class='fan-description'><p>Turn Websites into Apps on Your Mac</p>
</div>
            </div>
            </div>
</div>

<hr class='fan-of-the-week-separator' />


<div class='site-main'>

    <div class='main-content'>

        
        
        
        <div class='posts' role='main'>

            <article class="post post-65687 type-post status-publish format-standard hentry category-reviews tag-education tag-ios tag-utility" id="content">

    <header class='post-header'>

                    <div class='post-date'>
                <time datetime="2021-01-11T16:53:37-05:00"></time>            </div>
        
        <h1 class='post-title'>
            Puppr Review: Teach Your Dog New Tricks        </h1>

                    <div class='post-author'>
                <a class="post-author-link" href="https://www.macstories.net/author/alexguyot/" rel="author">By Alex Guyot</a>            </div>
        
    </header>

    <div class='post-content '>
                        <div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610396427912.png" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610396427912.png" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p2">I came across <a href="https://apps.apple.com/us/app/puppr-dog-training-tricks/id1199338956" rel="noopener noreferrer">Puppr</a> during its recent feature as Apple&rsquo;s <a href="https://apps.apple.com/us/story/id1475030041" rel="noopener noreferrer">App of the Day</a> and decided to give it a try. The app is a simple and fun instructional tool for teaching your dog new behaviors and tricks. Since I&rsquo;ve been staying with my parents for the last couple of months, I decided to take it for a spin doing some training with the family dog.</p>
<p id="p3">Puppr&rsquo;s Home view consists of a scrolling list of categories for dog lessons. You can start simple with the &lsquo;New Dog&rsquo; or &lsquo;Basics&rsquo; categories, but it quickly ramps up from there. Each category consists of a series of behaviors or tricks, and tapping one opens its details view. Within this view you can see a brief video of the trick in action with a real dog. There&rsquo;s also a difficultly rating, a description, and a badge for whether it&rsquo;s safe to teach this trick to puppies. Each trick includes a status dropdown which you can use to note that you&rsquo;re in progress of teaching it to your dog, or that your dog has mastered it.</p>
<p id="p4"><span id="more-65687"></span></p>
<div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610398820902.png" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610398820902.png" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p6">Below the details you&rsquo;ll get into the steps to teach the trick. Tricks are broken down into a series of steps that ramp your dog up to the full trick. Each step includes a brief, informative instruction on what its goal is and how exactly to perform it. Instructions break down when you should add in verbal cues to the tricks, and when you should click your clicker.</p>
<p id="p7">A clicker, if you haven&rsquo;t used one before, is a tool for training dogs which literally just makes a loud click sound when you press it. You can use your own clicker if you have one, but Puppr actually comes with one built into the app that you can use as well. The clicker is a large button in the center of the bottom tab bar which causes your device to emit a clicker-like sound. Make sure to turn your volume up so that your dog can clearly hear it.</p>
<p id="p8">Rather than human user profiles, in Puppr you can create profiles for dogs. Each profile lets you enter a name, age, breed, and picture. The app then keeps track of which tricks you&rsquo;ve taught, or are in the process of teaching, to each of your pets. The profile tab also features a list of badges which you can earn over time. I haven&rsquo;t paid much attention to this, but if you&rsquo;re getting serious about dog training then the badges can be a fun way to keep the habit up (badges accrue for things like training multiple days in a row or teaching certain numbers of tricks).</p>
<div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610397351914.png" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/Image-1610397351914.png" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p10">My family dog &mdash; Gracie the Australian Shepherd &mdash; already has her basics down from previous training, so I wanted to try out something more difficult. I found a category of tricks called &ldquo;Circus&rdquo; and started teaching her &ldquo;Hooped Arms.&rdquo; This is a trick where you form a hoop with your arms and have your dog leap through it.</p>
<p id="p11">I took some videos of the process to show Gracie&rsquo;s progress, which was surprisingly rapid following Puppr&rsquo;s excellently laid out steps. First I placed my hand against the wall close to the floor and had her jump over that:</p>
<div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384879612.gif" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384879612.gif" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p13">Once Gracie was consistenyly jumping over my straight arm, I moved onto step 2. This time I made a hoop against the wall and had her jump through it:</p>
<div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384903197.gif" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384903197.gif" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p15">Finally, I moved away from the wall entirely and had her jump through a midair hoop:</p>
<div class="media-wrapper"><img src="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384925318.gif" alt=""><p class="image-caption"><a class="view-full-size" href="https://d8fa96d6061491bec818-41a52a109fa0fefb17700938627149a6.ssl.cf1.rackcdn.com/animated-1610384925318.gif" target="_blank" rel="noopener noreferrer"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 120 120"><path d="M71.2 48.8c1.6 1.6 4.1 1.6 5.6 0L112 13.6V32c0 2.4 2.2 4.4 4.7 3.9 2-.3 3.3-2.2 3.3-4.2V4c0-2.2-1.8-4-4-4H88.2c-2 0-3.8 1.4-4.2 3.3-.4 2.5 1.6 4.7 4 4.7h18.4L71.2 43.2c-1.6 1.6-1.6 4.1 0 5.6zm20.8-.9V104c0 4.4-3.6 8-8 8H16c-4.4 0-8-3.6-8-8V36c0-4.4 3.6-8 8-8h56.1c1.1 0 2.1-.4 2.8-1.2l5.1-5.1c.6-.6.2-1.7-.7-1.7H12C5.4 20 0 25.4 0 32v76c0 6.6 5.4 12 12 12h76c6.6 0 12-5.4 12-12V40.6c0-.9-1.1-1.3-1.7-.7L93.2 45c-.8.8-1.2 1.8-1.2 2.9z"></path></svg></a></p></div>
<p id="p17">Gracie&rsquo;s still not quite as fluid as the dog in the Puppr video,  and she doesn&rsquo;t appreciate when I try to raise the hoop to my waist level, but we&rsquo;re getting there. She knows the trick now, and just needs some more practice to smooth it out and start jumping higher. Overall, I was very impressed by how easy and straightforward it was to teach something that looked quite complex using Puppr&rsquo;s instructions.</p>
<p id="p18">Not every trick will go as easily as this one, which was only rated at 2 out of 4 bones (the app adorably rates with bones instead of stars) in difficulty. That said, many of the more advanced tricks build on skills taught in easier ones, and Puppr calls this out. For example, in Puppr&rsquo;s tips section for Hooped Arms (tips can be found at the bottom of each trick) it mentions that your dog might struggle to get its back legs through the hoop. If this is the case then you should try teaching the simpler &ldquo;Orbit&rdquo; or &ldquo;Back Up&rdquo; tricks in order to improve their rear end awareness. Tips like these are extremely valuable to me as a complete amateur in dog training. Gracie didn&rsquo;t have that particular problem, but if she had then I wouldn&rsquo;t have known how to approach resolving it without the app&rsquo;s advice.</p>
<p id="p19">Puppr is a <a href="https://apps.apple.com/us/app/puppr-dog-training-tricks/id1199338956" rel="noopener noreferrer">free app on the App Store</a>. There are quite a few tricks available (including the Circus pack that I used) entirely for free. If you want to try some of the paid ones, you can unlock all current and future lesson packs via a $13.99 in-app purchase, or you can buy packs individually for a smaller price. The app offers a service called Puppr Premium as well, which is a $12.99/month or $99.99/year subscription (with a 7-day free trial). Puppr Premium unlocks all current and future lesson packs, and also gives you access to a live chat service with Puppr&rsquo;s trainers where you can ask them questions about any issues you might be having while training your dog.</p>
<p id="p20">The app also features a &lsquo;Puppr Shop&rsquo; tab which includes Amazon Affiliate links to various training treats and equipment, as well as other dog-related products. This provides another nice way to support the app if you like it, and links to some good options if you aren&rsquo;t sure what to purchase for your pet.</p>
            </div>

    
        <footer class='post-footer'>
        <div class="post-tags">Tags: <a href="https://www.macstories.net/tag/education/" rel="tag">education</a>, <a href="https://www.macstories.net/tag/ios/" rel="tag">iOS</a>, <a href="https://www.macstories.net/tag/utility/" rel="tag">utility</a></div>        </footer>

    
    
            <div class='club-after-content'>
            <div class='club-call-to-action'><div><img class='club-logo' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-gold.svg' alt='Club MacStories'></div><div class='club-button'><a class='button button-gold button-border-gold button-bordered' href='https://club.macstories.net/?utm_source=ms&#038;utm_medium=web'><span class='button-text'>Sign Up</span></a></div></div><div class='club-description'><h3 class='club-title'>Unlock MacStories Extras</h3><div class='club-description-content'><div class='club-body'><p>Club MacStories offers exclusive access to <strong>extra MacStories content</strong>, delivered every week; it&rsquo;s also a way to support us directly.</p>
<p>Club MacStories will help you discover the best apps for your devices and get the most out of your iPhone, iPad, and Mac. It&rsquo;ll also give you access to advanced iOS shortcuts, tips and tricks, and lots more.</p>
<p>Starting at $5/month, with an annual option available.</p>
<p><a href="https://club.macstories.net/?utm_source=ms&amp;utm_medium=web-inline" rel="noopener noreferrer"><strong>Join the Club</strong></a>.</p>
</div><div class='club-body'><p>A Club MacStories membership includes:</p>
<ul><li><strong>MacStories Weekly</strong> newsletter, delivered every week on Friday with app collections, tips, iOS workflows, and more;</li>
<li><strong>MacStories Unplugged</strong> podcast, published monthly with discussions on what we&rsquo;re working on and more;</li>
<li><strong>Monthly Log</strong> newsletter, delivered once every month with behind-the-scenes stories, app notes, personal journals, and more;</li>
<li><strong>Access</strong> to occasional giveaways, discounts, and free downloads.</li>
</ul>
</div></div></div>        </div>
    
</article>

<hr class='post-separator' />

<div class='post-author-info'>
    <div class='author-avatar'>
        <img class='author-avatar-image' src='https://www.gravatar.com/avatar/f0541d67822e4e8ab166f2856d05588f?d=404&s=250' alt='' />
    </div>
    <div class='author-info'>
                <p class='author-name'><a href="https://www.macstories.net/author/alexguyot/" title="Posts by Alex Guyot" rel="author">Alex Guyot</a></p>
                        <div class='author-bio'><p>Alex has been writing for MacStories since 2013. As a MacStories editor he covers Apple and related technology on the site and for <a href="https://club.macstories.net/" rel="noopener noreferrer">Club MacStories</a>. Alex also keeps the site running smoothly and works on new technology as MacStories&rsquo; senior software engineer.</p>
</div>
        <p class='author-contact-info'>
        <span class='twitter'>Twitter: <a href='https://twitter.com/_alexguyot' target='_blank'>@_alexguyot</a></span><span class='separator'> | </span>
        <span class='email'>Email: <a href='mailto:guyot@macstories.net'>guyot@macstories.net</a></span>
        </p>
    </div>
</div>



        </div>

    </div>

</div>

<footer class='site-footer' role='contentinfo'>

    <div class='about-social'>

        <nav class='about'>
            <ul id="menu-footer" class="menu"><li id="menu-item-54441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54441"><a href="https://www.macstories.net/about/">ABOUT</a></li>
<li id="menu-item-54439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54439"><a href="https://www.macstories.net/club/">MEMBERSHIP</a></li>
<li id="menu-item-54440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54440"><a href="https://www.macstories.net/advertise/">SPONSORSHIP</a></li>
<li id="menu-item-54438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54438"><a href="https://www.macstories.net/privacy-policy/">PRIVACY POLICY</a></li>
</ul>        </nav>

        <nav class='follow'>
            <ul class='menu social-media-menu'>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-twitter' href='http://twitter.com/macstoriesnet' target='_blank'></a>
    </li>
    <li class='menu-item'>
        <a class='social-media-button social-media-button-rss' href='https://www.macstories.net/feed/'></a>
    </li>
</ul>        </nav>

    </div>

    <span class='site-credits'>Code by <a href='http://avedesign.me' target='_blank'>Alessandro Vendruscolo</a> | Design by <a href='https://twitter.com/_silviagatta' target='_blank'>Silvia Gatta</a> | Hosted by <a href="https://www.macstadium.com/macstories" target="_blank">MacStadium</a> | <a href='https://www.macstories.net/acknowledgements/'>Acknowledgements</a></span>

    <span class='copyright'>Copyright 2021 MacStories, Inc. All rights reserved.</span>

    <span class='version'>v4.5.8
</span>

    <a class='logo' href='https://www.macstories.net/' rel='home'>
        <img class='logo-image js-logo-target' src='https://www.macstories.net/app/themes/macstories4/images/logo-shape-red.svg' alt='MacStories' />
    </a>

</footer>


<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/core.20200329.js'></script>
<script type='text/javascript' async src='https://www.google-analytics.com/analytics.js'></script>
<script type='text/javascript' async src='https://www.macstories.net/app/themes/macstories4/dist/autotrack.20200329.js'></script>
<script type='text/javascript' src='https://www.macstories.net/wp/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202102.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'92386366',post:'65687',tz:'-5',srv:'www.macstories.net'} ]);
	_stq.push([ 'clickTrackerInit', '92386366', '65687' ]);
</script>

</body>
</html>


