Mar
2
2011

iPad 2 Requires iTunes 10.2

Posted by at

Straight from Apple’s just-updated website, here comes a screenshot that confirms the iPad 2 needs a new version of iTunes, 10.2.

iTunes 10.2 still isn’t available for download and will likely be released in the next few days.

Update: and iTunes 10.2 is out.

• You should follow the author on Twitter here.

Tags:itunes